Question

The webinar "using PDF connectors" sample application

Greetings,

I am studying the webinar "Using PDF connectors" and crafted the sample application. In the Pdf Viewer component in Studio the PDF I picked shows.

But when actually starting the automation the Pdf Viewer does not show anything? See also attached screen shots.

Any ideas out there?

Regards Aad Slingerland

**Moderation Team has archived post**

This post has been archived for educational purposes. Contents and links will no longer be updated. If you have the same/similar question, please write a new post.

Correct Answer
March 28, 2018 - 9:15am

Pure by luck I found out the following:

Enable the ToolbarDevSection in de pdfviewer properties (as instructed in the video).

Start the automation in debug mode.

Klik on the (small) developerbutton in the upper right corner of the pdfviewer component in the windows form and select (for example) Highlicht Lines.

The pdfviewer automagically shows the first page of the pdf.

See also two screen shots attached.

Regards, Aad Slingerland.

 

Comments

Keep up to date on this post and subscribe to comments

Pega
March 26, 2018 - 8:17am

To load a file into the PDF Viewer you need to set the FileName property to the path of your file.  If it is still not showing check the zoom controls to make sure it is large enough for you to see.

March 28, 2018 - 2:40am
Response to jeffbadger

Jeff,

That simply works. However, I followed to instructions in the webinair and used the connector property of the pdfviewer.

In the meantime I found out that when I click the developer toolbar (in the pdfviewer) the PDF pops up in the PDF viewer and I can continue the exercise (selecting text in the pdf and show it in a label control in the windows form) .

Thanks so far...

 

 

March 28, 2018 - 6:47am
Response to aad.slingerland

Hi Aad,

I followed the same webinar and this error appears for me too. I am not able to view the file on runtime. 

I tried giving the file location in PDF Viewer's filename property but that is not taking any value. Kindly tell me how did you solve it?

March 28, 2018 - 9:15am
Response to Sanskriti

Pure by luck I found out the following:

Enable the ToolbarDevSection in de pdfviewer properties (as instructed in the video).

Start the automation in debug mode.

Klik on the (small) developerbutton in the upper right corner of the pdfviewer component in the windows form and select (for example) Highlicht Lines.

The pdfviewer automagically shows the first page of the pdf.

See also two screen shots attached.

Regards, Aad Slingerland.