Question

Table does not exist error when creating a new case

Logged in as Admin user to a new application. Go to create a new case in Pega Express and get the error: "Table does not exist in database" Any suggestions?

***Edited by Moderator Marissa to update categories***

**Moderation Team has archived post**

This post has been archived for educational purposes. Contents and links will no longer be updated. If you have the same/similar question, please write a new post.

Comments

Keep up to date on this post and subscribe to comments

Pega
December 7, 2017 - 1:16pm

Hi William,

Could you please mention the version in which you have attempted this use case? (Specify if any framework) 

How did you create a new application? Please share the steps. This would help me in getting through a proper root cause of the issue. 

-Madhuri

December 7, 2017 - 1:39pm
Response to Madhuri

This is Pega 7.3.1 using Apache Tomcat and MSSql with split schema. I created the new application from the PegaRules designer studio by clicking the "Build Application" button from the Home tab. It gives me the user accounts I created and I logout and login as the new application Admin and try to create the case and it gives me the error. It gives the same error in Designer Studio and Pega Express.

December 7, 2017 - 2:49pm
Response to WilliamM0713

It seems there may be issue with my PegaData db connection.  I test the connection and it says my class is mapped to a table in PegaData which does not exist

 

Pega
January 17, 2018 - 8:48am
Response to WilliamM0713

Is the issue solved and any idea about how you ended up in this configuration?

Pega
January 18, 2018 - 8:14am
Response to kotil

I have seen earlier with some other customer similar kind of issue and the issue happened due to the fact that someone by mistake deleted the DB table . Not sure whether the same thing happened here or not 

January 31, 2018 - 10:14am
Response to Santanu

I have the same issue. What is the table missing from the database?