Discussion

Migration - Issue while deploying the RAP from 6.1 SP2 to 7.1.6

I am facing this issue while deploying the RAP from 6.1 SP2 to 7.1.6.

After we imported the product to 7 environment (note : my 7 environment is new with a blank DB) , I changedall the ruleset prerequisite to the needed rulesets and changes the ruleset 6.1 to peha ruleset 7. I save the application rule with the case types.

Now the problem is I can see my class structure but I am not being able to see the rules through Application explorer.

when I Search the rules through Record explorer i am being able to see the rules.

Even the rule is pointing to thecorrect ruleset version, but when i open the ruleset veriosn I see All Rules contained as 0. As well as I am not being able to see the Case types also through Case Explorer.

Please help. Thanks in Advance.

**Moderation Team has archived post**

This post has been archived for educational purposes. Contents and links will no longer be updated. If you have the same/similar question, please write a new post.

Comments

Keep up to date on this post and subscribe to comments

Pega
June 12, 2015 - 7:17am

Check wether you have any exceptoins in the log file for the R-A-P import process.

 

After importing the R-A-P make sure you run the following steps.

1) Run the Update Wizard from Update Existing applications landing page

2) Run Revalidate- Save for all rule sets

 

Let us know your observations.

 

June 12, 2015 - 7:30am

1. For Upgrade wizard:- This is a fresh install of PegaRULES Process Commander, so the Application Update Utility does not need to be run. this is the notification I am getting. Do you still want me to run the upgrade wizard?

 

2. For revalidating and save I tried revalidating and saving for 5 ruleset version but still couldnt see the rules either through App explorer or directly through the ruleset version.

 

P.S. I even tried to create a rule and save it. I was unable to see the rule through the App exp or in the ruleset it got saved.

Pega
June 12, 2015 - 9:10am

Hi,

Can you check whether your application rulesets are available in the PR4_RULE_RULESET table ?
 

Does your RAP have any Data-Admin-DB-Table rules which can override default database mappings for RuleSet class ?

 

 

June 12, 2015 - 9:55am

Hi Rmas6, I created a obj-browse on Rule-Ruleset-Name and showpage and could see my Rulesets there.

 

For Data-Admin-DB-Table rules which can override default database mappings I need to check will get back with that analysis.

Pega
June 12, 2015 - 9:57am

Addition to what Sudharsan has mentioned, you have to run the update wizard because you are taking the R-A-P from PRPC 6.2 SP1 and deploying into new Pega7 instnace.

 

As you mentioned you are also not seing the rule counts even after creating the new rules.

Can you check whether your newly created rules exists in the PR4_RULE_VW table and also make sure that all the triggers are enabled and working fine. When ever rule get created then PR4_RULE* trigger will automcatilly populate the records in PR4_RULE_VW  table and that data will be used to show the rule counts in rule sets.

 

 

 

 

June 18, 2015 - 5:20am

Sudharsan can you please explain in detail about "Does your RAP have any Data-Admin-DB-Table rules which can override default database mappings for RuleSet class ?"

 

How can we analyse this thing?

 

Pega
June 18, 2015 - 7:58am

Abhishek can you confirm whether all the triggers are enabled and working fine in rules schema?. All the rule counts are shown from the PR4_RULE_VW  table which is populated using database triggers.

the following query gives the information about whether your application rules present in this table

select * from PegaRULES.pr4_rule_vw where pyruleset like '%PIP%'

replace your ruleset name and check this count.

 

 

 

June 18, 2015 - 8:37am

Devendra If I fire the above querry and  get the result count as some number say "1256" so does that mean my triggers are working fine or there is some other way to find whether the triggers are working fine or not?

 

Pega
June 18, 2015 - 8:49am

Yes, if you have the records with your imported application rule sets then that means the import went successfully and triggers are working fine.

June 18, 2015 - 8:56am

thanks Dhevendra will try this and will get back to u.

June 19, 2015 - 5:54am

Hi Dhevendra, I tried running the querry u suggested and I did get a count for my ruleset. So this means the triggers are working fine bit still I am seeing my rules count on opening the ruleset version UI in Pega  as 0. (i.e. all rules = 0). Please suggest what else can I look into?

 

September 4, 2016 - 4:46am
Response to AbhishekG9395

Hi Abhishek,

Based on the comments received from Dhev and Vamshi, were you able to sort out this issue?  Or is the issue still open?

Regards,

Sumeet

Pega
June 25, 2015 - 4:39am

Abhishek,

I have quickly tried this scenario on Pega 7.1.8 build and I was able to import the 6.x R-A-P and able to see the content and rules couunts properly. is it possible to take the latest ML build (Pega 7.1.8) and try this out?

 

 

 

 

July 1, 2015 - 12:52pm

Abhishek,

 

can you check contents of Declare_AppExplorer page for the imported application and for PegaSample. 

 

Check if the data in the page is matching the App Struture or not

 

Vamshi