Question

Is it possible to increase the time interval of 120 seconds to prevent the "Unable to synchronize requestor withing 120 seconds" error?

We do have actions in our application that take more than 120 seconds and can not be faster. How can I prevent the "Unable to synchronize requestor within 120 seconds" by updating the interval of 120 seconds?

Regards,

Michiel

***Updated by moderator: Lochan to add Categories***

**Moderation Team has archived post**

This post has been archived for educational purposes. Contents and links will no longer be updated. If you have the same/similar question, please write a new post.

Correct Answer
March 24, 2016 - 8:47am

If you are sure this is not a performance issue, here are the settings:

  ("initialization/httpmaxlockattempts", 6);

  ("initialization/httplockretryinterval", 20000); (in ms)

default values indicated above = 6*20 (secs) = 120 secs.

These are prconfig settings and will require server restart.

Comments

Keep up to date on this post and subscribe to comments

March 24, 2016 - 8:47am

If you are sure this is not a performance issue, here are the settings:

  ("initialization/httpmaxlockattempts", 6);

  ("initialization/httplockretryinterval", 20000); (in ms)

default values indicated above = 6*20 (secs) = 120 secs.

These are prconfig settings and will require server restart.

March 24, 2016 - 10:00am
Response to KevinZheng_GCS

Hi Kevin,

Thank you for your prompt answer… I know 120 seconds might seem a performance issue… however not for two or three actions in our application which cost a lot of time.

Regards,

Michiel

April 1, 2016 - 1:43pm

Hi Kevin Zheng

Is there a way to increase this configuration only for specific action as only couple of use cases will take more than 120 secs

Amit

April 1, 2016 - 2:04pm
Response to AmitShekhar

no. But if your use case is only limited to a particular prpc node, then you can limit the scope to that node (e.g., agent node) by specifying node specific setting.

April 1, 2016 - 3:55pm
Response to KevinZheng_GCS

Thanks Kevin.