Question

Incorrect sql query. How do I get Pega to generate correct SQL query using function alias in a report?

Hello!
1. I have a simple function alias which takes 2 parameters.

2. I have a report definition. One of the columns uses my function alias, and one of the parameters is a value from a joined table (using Declare-Index)

3. In generated SQL I see that Pega tries to read the blob of the joined table trying to retrieve the 1st parameter, which it doesn't have to do, because the value is exposed (it hasn't been exposed via Pega though, I manually mapped the columns in the Class Advanced tab)

How do I get Pega not to read values from a blob?

***Updated by moderator: Marissa to close post***

This post has been archived for educational purposes. Contents and links will no longer be updated. If you have the same/similar question, please write a new post.

Comments

Keep up to date on this post and subscribe to comments

December 6, 2016 - 10:50pm

Hi,

Can you resave the Data-Admin-Database-Table entry for that particular class. You shall find it under SysAdmin -> Databse Table.

Open the entry for that class, save it and run test connectivity.

December 7, 2016 - 3:12am
Response to Shashidhar_Palle

Yes I tried, but still no help :(
May be Pega is keeping track of exposed properties somewhere... ?

Pega
December 8, 2016 - 5:56am
Response to AlekseiZ

Kindly share the following

  1. The database platform and version being used (including the JDBC driver version)
  2. The exception from the log file when the report definition is saved / executed
  3. Whether the case of the column is same as the property name
  4. DDL for the table and screenshot of the external mapping for the class