Discussion

HTTP Service is not responding

I have created a HTTP Service rule. In request I have given HTML PostData. In response I have given HTML Stream and a HTML Stream rule. When I have sent a http request from outside prpc(general html file) The response haven't been sent. Even when I try to run the Service HTTP there is no response.

***Updated by moderator: Marissa to close post***

This post has been archived for educational purposes. Contents and links will no longer be updated. If you have the same/similar question, please write a new post.

Comments

Keep up to date on this post and subscribe to comments

Pega
April 28, 2008 - 3:29pm

Hi,

As you don't state which version of PRPC you are currently using i'm going to assume for a moment that it is version 5.0 +

I have some questions for you:

1. Is this still a problem for you?
1. Which version of PRPC are you using?
2. Did you create the HTTP Service using the Service Accelerator?
3. What was the output of the service simulation test when you ran the HTTP Service rule?

April 29, 2008 - 12:30am

Hi

Yes the problem is still existing and I am using v54_relcand_0086 build.

I have created HTTP Service manually.
When I ran the HTTP Service test I got the over all result as Success and I hadn't got any Response Header Values (i.e showing only null values).

Pega
April 29, 2008 - 3:37am

OK, as i can't see the rules you created as a developer i'd try the following stepwise approach:

1. Try creating a new HTTP service with the the Service Accelerator and then test that works using the Service simulator by running it, first with the same response object then a new one (options in the run dialog)

2. When successful then change the Accelerator generated HTTP service one step at a time until it has the functionality you need including the post etc

3. At each step retest the service to isolate any functional changes that may not work in configuration

May 12, 2008 - 5:44pm

Hi. I've created an HTTP Service manually (without the Service Wizard) and it works fine. My request has MapTo as HTML post data. In the response, the 'Default' condition has MapFrom as HTML Stream.

I invoked the HTTP service using
http://<server>:<port>/prweb/PRHTTPService/<service pkg name>/<service classname>/<service method name>

When unit testing the service, I get all statuses as Success and response from the stream is displayed.

Have you tried running tracer when unit testing the service? Maybe your service activity is failing?