Question

Flow becomes idle in tracer when Assignment shape used

Hi All,

I have created a case type and added one flow to launch that case type. As I am having an assignment shape followed by a screen flow(sub process) in my flow , I am getting the summary of the case. In tracer I can see the flow becomes idle in that time when it reaches assignment. I tried by removing the assignment shape and it works well.

Can any one suggest me a solution.

Main flow: Standard flow

Subflow: Screenflow.

**Moderation Team has archived post**

This post has been archived for educational purposes. Contents and links will no longer be updated. If you have the same/similar question, please write a new post.

Comments

Keep up to date on this post and subscribe to comments

December 18, 2017 - 12:55am

HI Suhail,
As the execution reached the assignment shape in a flow, it would wait for user Action to proceed forward to the subflow.
If my understanding is not inline with your configuration please let me know.
You can attach screens of your configuration as well.

Thanks,
Ujjwal

December 20, 2017 - 12:06am
Response to UjjwalShukla_GCS

Hi Ujjwal,

There is a correction in my post. Actually I am getting the summary page, when I am launching the case from my portal. It is not executing the Standard flow when there is an assignment shape. I have a connector shape to call one service , that's why i have used standard flow. But this is working fine when I used a screen flow.

Please find the attached screens. I don't think there is an issue with flow action coz I have tried two or three flow actions. When I removed the assignment shape, the flow executed perfectly fine.

 

Thanks

Pega
December 18, 2017 - 5:51am

Hi Suhail,

Thanks for posting on PSC.

I have tried replicating the use-case in-house. In my case, the assignment is moving within screen-flow as well.

And it isn't getting idle in assignment shape. It's calling CompleteAssignment and FinishedAssignment and other activities as expected for assignment within screen-flow.

I suspect, there is a problem with flow action at your end. Kindly verify and try to run it independently to observe whether it's working correctly or not. 

Also, share design and tracer capturing the details. Please provide more description of the issue and what you are trying to achieve.

Regards,

Asif

December 20, 2017 - 12:06am
Response to Asif Hasan

Hi Asif,

There is a correction in my post. Actually I am getting the summary page, when I am launching the case from my portal. It is not executing the Standard flow when there is an assignment shape. I have a connector shape to call one service , that's why i have used standard flow. But this is working fine when I used a screen flow.

Please find the attached screens. I don't think there is an issue with flow action coz I have tried two or three flow actions. When I removed the assignment shape, the flow executed perfectly fine.

 

Thanks

December 19, 2017 - 12:19am

Hi Ujjwal/Asif,

There is a correction in my post. Actually I am getting the summary page, when I am launching the case from my portal. It is not executing the Standard flow when there is an assignment shape. I have a connector shape to call one service , that's why i have used standard flow. But this is working fine when I used a screen flow.

Please find the attached screens. I don't think there is an issue with flow action coz I have tried two or three flow actions. When I removed the assignment shape, the flow executed perfectly fine.

 

Thanks

Pega
December 27, 2017 - 4:36am
Response to SUHAILHASHIMP

You mean to say that when you have assignment shape and ScreenFlow present in flow, only ScreenFlow is executing?

If yes, What you're trying to achieve in the assignment shape? Share the configuration of it as well.