Question

Error message while trying to sort column values in a repeat grid

I have implemented a repeat grid in a Modal Dialogue.The source of Repeat Grid is property. While sorting, If there are more than one values in the repeat grid I am getting an error message

Cannot get property information for: ..PXXXXXName.  Details: Invalid value for aClassName, aPropertyName passed to com.pega.pegarules.data.internal.clipboard.PageComparator.getDefaultComparator(Executable, String, String) 

While, if there are no values in the Grid I am not getting any exception or error message on clicking to sort.

It is failing in @Baseclass.pzSortClipboardData activity.

Please do not suggest the solution as mentioned here https://pdn.pega.com/support-articles/invalid-value-aclassname-apropertyname-passed

or here https://pdn.pega.com/support-articles/sorting-issue-column-embedded-repeating-grid

as I dont have a nested Grid.

**Moderation Team has archived post**

This post has been archived for educational purposes. Contents and links will no longer be updated. If you have the same/similar question, please write a new post.

Comments

Keep up to date on this post and subscribe to comments

Pega
March 16, 2017 - 12:06am

Hi Ashish,

-Could you let us know the Pega version that you are using.
-What is the mode of row operations selected?
-Also attach screenshots of how the grid is configured. 

I created a test use case in 7.1.6 where the repeat grid is added in the modal dialog and sorting is enabled. I am unable to see the error that you are getting. 

Regards,
Evita.

March 16, 2017 - 9:54am
Response to Evita_08

Hello Evita,

Thanks for replying.

I am using Pega 7.1.9. 

I am attaching a word file containing screenshot of the design configurations. I have hidden the property names for privacy reasons. So forgive me if you find it untidy. I am getting the issue if I click on any column to sort it.

Please also suggest, If I should raise a Pega-SR for this.

PFA

March 16, 2017 - 2:44am

Hi Ashish,

 

I didn't understand two dots below, may be u haven't defined the property accurately.

..PXXXXXName

March 16, 2017 - 6:57am
Response to PRASHANTS-1

Hi Prashans-1,

Thanks for replying. I have manually edited the property name while pasting it here.