Question

Error 503: PegaRULES server not available while accessing PEGA Application

I'm novice to PEGA and facing the issue as follows.

Getting the message as "Error 503: PegaRULES server not available" after recycling the JVM. Attaching the complete log file PegaRULES-2017-Dec-28.txt downloaded from the SMA. Please review the log file and advise.

**Moderation Team has archived post**

This post has been archived for educational purposes. Contents and links will no longer be updated. If you have the same/similar question, please write a new post.

Correct Answer
December 29, 2017 - 7:55am

Hi,

After going through the log file we can see node initialization failed, please shutdown all nodes, truncate pr_sys_statusnodes table and start the nodes one by one.

Comments

Keep up to date on this post and subscribe to comments

December 29, 2017 - 2:04am

Hi Vellanki,

Is your system a fresh installation? If not, did you make any recent changes to JDBC data source level?

I did a quick search and I found the article that might help.

http://www-01.ibm.com/support/docview.wss?uid=swg21244805

The simple solution is to use an XA driver.

-Ravi.

December 29, 2017 - 4:07am
Response to Raviteja_GCS

Hi Ravi,

Thank you for the response. 

on your questions, our system is not a fresh installation and we didn't make any changes to JDBC data source level. And from the beginning the driver is XA driver itself. The issue is occurring post recycling the JVMs. Earlier, we validated the system and we were able to connect to database and able to make all the transactions. 

 

Regards,

Ravi Vellanki

 

 

December 29, 2017 - 7:55am

Hi,

After going through the log file we can see node initialization failed, please shutdown all nodes, truncate pr_sys_statusnodes table and start the nodes one by one.

December 29, 2017 - 10:05am
Response to SudhakarReddy

Hi Sudhakar,

Thanks so much.  We truncated pr_sys_statusnodes table and restored. 

That resolved our issue and able to do transactions now. Any specific error log info you found in the previous logs. We are still seeing that InitializationFailedError: PRNodeImpl init failed  in our latest log file post the issue got resolved. Please find the latest log file Plain text icon PegaRULES-2017-Dec-29.txt as attached. 

Thank you,

Regards,
Ravi Vellanki