Question

Encrypt Blob Option is not Editable in few concrete Class

I have implemented site specific Cipher, and able to encrypt few work object by enabling the Encrypt Blob Option.

But found few work object class in which Encrypt Blob Option is UnEditable.

 

**Moderation Team has archived post**

This post has been archived for educational purposes. Contents and links will no longer be updated. If you have the same/similar question, please write a new post.

Correct Answer
December 22, 2016 - 1:24am

Working Solution suggested to me is,

truncate the table in lower environment and then you can check the check box, and move this change to other environment.

I did a work around for this, I changed the table mapping to a temperatry table and then checked the check box and move this to other environment

Comments

Keep up to date on this post and subscribe to comments

December 9, 2016 - 5:32am

Hi,

I verifed the condition for the Encrypt Blob check box, the condition is as attached.

It means that, in order to enable the checkbox there has to be atleast one instance for that class.

Just create one instance and check. Let us know if it helps

Thanks,

Bala

December 22, 2016 - 1:18am
Response to Bala_Nagendra

Thanks for the reply Bala,

Nice to get the conversation going ☺

I raised a SR and got help from there they said that to make it enable there has to be zero instance.

So the solution is truncate the table

Mod
December 22, 2016 - 1:43am
Response to RasaiyaNadar

Hi Ross,

It would be great if you could let us know the SR number so that we could tag it with this post for future reference.

Regards,
Lochan  |  Community Moderator  |  Pegasystems Inc.

Lochana | Community Moderator | Pegasystems Inc.

December 9, 2016 - 5:34am

Also, just a quick workaround.Check below steps which can help,

1) Open your class

2) In Settings section, change the value in This class dropdown 

3) Resave the class rule.Encrypt Blob will be enabled.

I had similar issue , I just changed the class value and switched to original value and resaved the rule. It worked for me.

December 12, 2016 - 1:50am

Hi,

As per the condition in the above attached screenshot, Encrypt Blob checkbox will be enabled when there are no instances to that class.

Thanks,

Bala

December 22, 2016 - 1:24am
Response to Bala_Nagendra

Working Solution suggested to me is,

truncate the table in lower environment and then you can check the check box, and move this change to other environment.

I did a work around for this, I changed the table mapping to a temperatry table and then checked the check box and move this to other environment