Question

Email Listener not not able to process email

We are having issues in email listener where some of the emails are not being processed by Pega. Users are forwarding emails to application email account and report it when thy don’t see it in application.

In the log file we are observing exception like below. How we will resolve this exception?

2017-06-01 22:06:01,488 [ EMAIL-Thread-19] [ STANDARD] [ ] [ ] ( services.email.EmailListener) ERROR EMAIL.JWCAEmailListener.Listener - Caught javax.mail.AuthenticationFailedException when attempting to get new messages
javax.mail.AuthenticationFailedException: Read timed out
at com.sun.mail.pop3.POP3Store.protocolConnect(POP3Store.java:209)
at javax.mail.Service.connect(Service.java:366)
at com.pega.pegarules.integration.engine.internal.services.email.EmailListener.openMailFolder(EmailListener.java:3509)
at com.pega.pegarules.integration.engine.internal.services.email.EmailListener.emailReceive(EmailListener.java:3646)
at com.pega.pegarules.integration.engine.internal.services.email.EmailListener.oneIteration(EmailListener.java:2864)
at com.pega.pegarules.integration.engine.internal.services.email.EmailListener.run_(EmailListener.java:2737)
at com.pega.pegarules.integration.engine.internal.services.listener.ServiceListenerBaseImpl.run(ServiceListenerBaseImpl.java:454)

**Moderation Team has archived post**

This post has been archived for educational purposes. Contents and links will no longer be updated. If you have the same/similar question, please write a new post.

Comments

Keep up to date on this post and subscribe to comments

Pega
June 7, 2017 - 5:33am

Hi Amit,

Can you provide complete stack trace for the exception including caused by? Also mention the version of PRPC.

Regards,

Basavaraj

June 7, 2017 - 2:52pm

Can you check the test connectivity whether the password is given or not

1. Go to Email Accounts (Designer Studio --Integration -- Email - Email Accounts)
2. Select FaxEmail Account or Default Email Account
3. Do test connectivity test for the sender (Click on test connectivity button at Sender)

We see this issue when the hostname is changed or password is incorrect.

June 7, 2017 - 10:21pm

Hi Amit,

Can you answer or comment on the following points:

1. Is it happening for all the emails or some of the emails?

2. Emails are with attachments or without attachments?

3. Size of the attachments?

4. Did you check the connectivity for the email account?

5. If there are any authentication erro, did you check with the email server folks if they reported any issues at the same given time?

Regards,

Mukul