Question

Connect Rest Issues

My first question : Can a Connect Rest (POST method) accept xml as input and give JSON as response back. ( It worked successfully from SOAP UI )

I used Rest integration Wizard. gave the URL details selected POST as resource method and added header.

For data model . I entered Header as "application/xml"

pasted the xml which i used soap ui and clicked the RUN button. The call was successful and gave me the REST response (I am attaching a document for reference). Tried to complete the connect rule but it failed in completing with error and attached the error log.

Now that we can see a successful response back for the input xml we are still not sure what could be the reason behind the error we see in the log and why the connect rest rule is not being created.

Please find the attachment for screen shots.

***Edited by Moderator Marissa to update SR Details***

***Edited by Moderator Marissa to close post to future comments***

Group Tags

Comments

Keep up to date on this post and subscribe to comments

December 20, 2017 - 11:58pm

Hi ,

Answering your first question yes you can give xml as input and can get json as response .

Which Pega Version your using .

Enable debug for pyinvokerestconnector  and share the complete stack trace of the issue, it's not clear from the document .

You may need to raise a SR with Pega Support  to troubleshoot this issue .

 

 

December 21, 2017 - 5:13am

Hi Sapthagiri,

After looking into your document, the input request data is being treated as a JSON string while creating the necessary resources and its been failing during the generation of classes. So we need to find the root cause behi nd the treating of input request data as JSON instead of XML. Can you please share the screenshots of your complete steps of the REST wizard from Connection to Review step to check your configuration.

Regards

Mahesh

December 22, 2017 - 3:12pm

Hello Sapthagiri,

Try once creating the connect-rest rule manually instead of the wizard  and test the usecase .

You can create the datamodel n number of times with different names from the wizard .

Thanks,

Arun

December 27, 2017 - 1:26pm
Response to Arun_Mahanty

Hi Arun. I tried this and saw an issue with the response being parsed.  Verified the response data model thoroughly and still I saw that the parsing issue. Tracer didnt identify any fail steps. Not sure what could be the reason behind that. Planning to open a SR so that we can trouble shoot thing in live.

 

Regards

Sapthagiri

Mod
December 27, 2017 - 9:20pm
Response to SapthagiriP

Hi Sapthagiri,

Do let us know back here, the SR number once you have opened it. We will continue tracking it through this post.

Regrads,

Lochana | Community Moderator | Pegasystems Inc.

January 26, 2018 - 4:32pm

Hi @SapthagiriP,

While going through your related SR, I see that it was closed as you were unable to debug at this time. Please let us know if you re-open the SR.

Thanks!

Marissa | Community Moderator | Pegasystems Inc.