Question

Can you modify the permissions of files generated by the Connect-File rule?

Do we have an option to modify the permissions of the files which are generated by Connect File rule.? I have a requirement where from a file is being created in Pega from a report definition, and then this file is sent to a directory inside the pega server via connect-file method. Everything works fine from file creation and transfer. However when I navigate to the folder to open the file, it says that I dont have access. Since we are using Unix server, if I manually change the mod to 777 or something similar then I am able to open it. I need to go to the bash shell of the server admin (oracle this case) as a super user and change the permissions.

Is there any OOTB way by which I can set the permissions on the file as it is created and transferred?

***Updated by moderator: Marissa to close post***

This post has been archived for educational purposes. Contents and links will no longer be updated. If you have the same/similar question, please write a new post.

we need to have this since this file would be picked up by another application for further processing.

Any help would be appreciated

Correct Answer
May 28, 2015 - 9:45am

Thanks every one for their help especially Pradeep for the insight. The issue is addressed, as we wrote a cron job on the server to monitor the folder and update the permissions on all new files that are created there.

Comments

Keep up to date on this post and subscribe to comments

May 8, 2015 - 11:39am

I don't believe we have this functionality yet but it can certainly be accomplished in java. You'd have to enter an enhancement request - this will be a nice feature to have.

May 11, 2015 - 1:23pm

I assume you see the owner of the file on the server as the OS user who started the PRPC JVM? If yes, you could ask your admins to change the default 'umask' value for this user (change default new file permissions) so other users can read/write. Not sure if this helps you

May 14, 2015 - 5:52pm
Response to PradeepRaghuram_GCS

Thanks a lot Pradeep for the response. Can you let me know if this "umask" can only be run by a Admin and not by any other user using the SUDO bash command in  the console? I tried to run this by going into the bash shell with the Sudo command but it didn't seem to work.

May 14, 2015 - 6:11pm
Response to DHARA001

Hi Anoojit

I don't know the Unix environment you are running but you can edit the user profile or bash_profile file and include the mask line like below. The below entry means new directories will be created with 775 and files with 664 permissions. This is an example and you can read the man page if required to decide on a value that fits you.

umask 002

May 14, 2015 - 6:22pm
Response to PradeepRaghuram_GCS

Hi Anoojit,

Logged in as the PRPC OS user, check the current umask by entering just "umask" with no options. Then verify against the files created and see if the permission is what the umask defines. You should then update the user profile mentioned in my last reply

May 28, 2015 - 9:45am

Thanks every one for their help especially Pradeep for the insight. The issue is addressed, as we wrote a cron job on the server to monitor the folder and update the permissions on all new files that are created there.