Question

Buttons in email body

In the user email, the buttons are coming like below.

please suggest. V7.1.7. Section included in Corr rule.

Button in email.png

**Moderation Team has archived post**

This post has been archived for educational purposes. Contents and links will no longer be updated. If you have the same/similar question, please write a new post.

Comments

Keep up to date on this post and subscribe to comments

June 21, 2016 - 4:58am

Hi Chaitanya,

I would request you to kindly provide brief explanation of your use case along with the steps you are following which would be helpful for us to answer the query.

Kindly add your PRPC version as well.

Regards,

Ravi

June 22, 2016 - 12:46am
Response to cr001

V7.1.7

Created Corr rule for email template.

Buttons referred in section. The section referred in corr rule.

Email triggrred to user. In the email buttons are looking as pointed above.

Pega
June 22, 2016 - 1:23am

Pega
June 22, 2016 - 1:51am
Response to Gangababu

Please try below steps.

you have created a section rule with embedded image. Hence, by default the image reference would be something like this: img src=webwb/KeyEnergyServices.png We need to provide the absolute path by following the steps below: 1) In your section, uncheck the auto-generated HTML checkbox in HTML tab and write the image tag as follows in the HTML source: IMG src='/webwb/KeyEnergyServices.png' 2) Now include this section in the correspondence Fragment which should then work as expected.

Pega
June 22, 2016 - 3:02am
Response to Gangababu

How are you triggering email? If you are using "SendCorrespondence" flow action in a flow you should see the image. If you use "SendEmailNotification" to trigger email you couldn't see the image in email.

August 7, 2016 - 4:44pm
Response to Gangababu

Am using SendEmailNotification activity for sending emails. Can you please suggest how to enable option to send images , buttons which are referred in the correspondence rule. Before calling activity and using property set corr method to trigger the corr rule.

June 23, 2016 - 1:32am
Response to Gangababu

it's not an image. I have used pega default buttons.

June 21, 2016 - 5:20am

Did you use any custom CSS/icons or images for buttons? It looks like the path to the image/css is missing. If it is a icon/image you are referring you need to pass the correct path like directoryName/FileName.Extentions

Ex: webwb/unlock.png

June 22, 2016 - 12:47am
Response to Prasad_Lagadapati

No CSS/icons or images.

Tried with standard / simple / strong button formats.

Pega
July 11, 2016 - 7:45am

Hi Venkata,

Is the issue here that you don't want the buttons to appear at all in your email ? Or if you do want them : what is the purpose of the buttons: what is supposed to happen if the email recipient clicks on the button ?

Thanks,

John

 

August 7, 2016 - 4:42pm
Response to JOHNPW_GCS

Buttons should appear in the email. Onclick of buttons it can you to the portal as referred in the navigating URL on clik.

August 11, 2016 - 2:39am

Hi Venkata

Could you send the screenshots of how you are configuring the "SendEmailNotification" activity. Screenshots will help us enormously.

November 25, 2016 - 3:30am

Hi All,

Actually issue i'm facing is very bit same as the main problem thread, but functionality wise it is not working. So below is the requirement:
To give a user a simple feedback form with 2 radio button and submit button, and once they select any one radio button, and clicks on Submit then it should send the handler (backend support team which will have a fix email address to get all feedback responses). 

Approach : I'm able to get the email on my gmail account. This is done using a Section rule (it has 2 radio btn and a submit btn) which is used in Correspondence which is sending email to my account. (Till here all is fine).
Now when this section appears in mail, i want to make that Submit to send back the response back to support team email (all this is done in inline mail only, i'm not sure whether it  is feasible !!)

Problem: I tried to call click action on Submit button but somehow it's not working, even remotely. Pls let know any link or way on how to do read back the mail with response on clicking button.

Note: Have created SOAP service, and an activity to read the input. Also tried DWA, and Survey feedback (ootb) but due to some reason we can't approach with that.

Thanks !

Mod
November 25, 2016 - 3:33am
Response to HarshitS0328

Hello!

To increase the visibility for your question, we have created a new post for you. Please update that to continue the troubleshooting. 

Requirement: To give a user a simple feedback form with 2 radio button and submit button, and once they select any one radio button, and clicks on Submit then it should send the handler

Regards,
Lochan  |  Community Moderator  |  Pegasystems Inc.

Lochana | Community Moderator | Pegasystems Inc.

November 29, 2016 - 8:02am

hi Chaitanya,

in the email correspondence,  only inline styles will work.

custom html may  work for you ... replace the pega button with custom button with inline style.