Question

Webchat reload loading the Resolve action in chat window

In Pega Infinily I have created this Webchat interface and the added the Mashup code(as it is generated on the Mashup tab of the interface) in a sample webapp running on Tomcat.

<!-- ********************** Begin Pega content ********************** -->
<script src ='https://localhost:8443/prweb?pyActivity=pzIncludeMashupScripts'></script>
<div data-pega-gadgetname ='PegaGadget'
data-pega-action ='createNewWork'
data-pega-action-param-classname ='Work-Channel-Chat'
data-pega-action-param-flowname ='pyStartCase'
data-pega-isdeferloaded ='false'
data-pega-applicationname ='ChatbotApp'
data-pega-threadname ='STANDARD'
data-pega-resizetype ='stretch'
data-pega-url ='https://localhost:8443/prweb/PRChat'
data-pega-action-param-parameters ='{"channelId":"bot66c445b76b24481e899b7ba4ca5bc41d"}' ></div>

<!-- ********************** End Pega content ********************** -->

When I open the Sample app, the chat console is loaded -

However, on refresh of the browser screen, the chat console loads the Resolve action. This happens sporadically and goes away on subsequent refresh.

With browser refresh this is reproduced more frequently. Initially noticed this when closing the browser and opening the chat url in browser intermittently.

Was comparing the trace of good and bad scenario. In good scenario the pxAcquireInteraction java step 2 is calling the pzCloseExpiredInteraction while in bad scenario the svcAddWorkObject activty is being called.

This looks like a problem when the channelUser, pyBotConfig and pyInteractionCase is exist in the clipboard in pega for the interaction and chat session is not able to acquire the existing session and initiate the interaction again.

Have anybody seen this before? How to get rid of this?

***Edited by Moderator Marissa to update SR Details***

Group Tags

Correct Answer
February 15, 2019 - 1:53pm

Thanks. 

There was a BUG about this behaviour. It was fixed in 8.2 release only.

Piotr

 

Comments

Keep up to date on this post and subscribe to comments

February 12, 2019 - 9:36am

Have anybody seen this before? How to get rid of this?

February 13, 2019 - 10:20am
Response to MilanP

Hi,

What version it is ? 

February 13, 2019 - 12:45pm
Response to MilanP

The screen shots are from Pega 8.1.

Can see the same behavior in 8.1.2 as well.

 

February 15, 2019 - 1:53pm
Response to MilanP

Thanks. 

There was a BUG about this behaviour. It was fixed in 8.2 release only.

Piotr

 

February 18, 2019 - 6:45am
Response to Piotr Kulig

Oh! So would there be any patch on 8.1 for this?

February 18, 2019 - 7:32pm
Response to MilanP

Hello,

I think, you need to raise SR for that, this way it could be included in next patch release.

Piotr

February 19, 2019 - 4:26am
Response to Piotr Kulig

Thanks Piotr! You have been very helpful. 

February 20, 2019 - 8:43am
Response to MilanP

Hi @MilanP,

Please let us know the SR ID when you open your Support Request so that we may track this for you!

Thanks!

Marissa | Community Moderator | Pegasystems Inc.

February 21, 2019 - 6:51am
Response to MarissaRogers

SR-C92195 is submitted to GCS.

Pega
February 12, 2019 - 4:36pm

I think this could be an issue with cookies/browser session. Does the issue persist when you run the chat from an incognito browser tab?

February 13, 2019 - 4:36am
Response to perrs

Hello Perry,

I am running the Pega instance in chrome and chat in IE to rule out the issue with cookies/browser session. Still see the issue. But I am not able to verify this in incognito tab as my organization has disabled this option from browsers.

February 15, 2019 - 7:20am
Response to MilanP

I tried in in Incognito as well, Still see the issue.

June 20, 2019 - 5:30am

Hi MilanP,

Can we implement webchat functionality on standalone pega8 or do we need customer service framework ?

Thanks

Som