Question

Wait shape is not working for time interval

Hi ,

The process has to be suspended for 2 mins .After the configured interval is passed,the process should progress forward automatically . but currently it's not moving forward to create an assignment automatically.

Time Interval : 2 Mins. and "pyContinueAfterWait" flow action is defined on outgoing connector of wait shape.

PRPC;71.8

Please suggest.

**Moderation Team has archived post**

This post has been archived for educational purposes. Contents and links will no longer be updated. If you have the same/similar question, please write a new post.

Comments

Keep up to date on this post and subscribe to comments

Pega
May 12, 2016 - 3:16am

Is the Case configured with Default locking ?

Also can you check if the Case is locked during that time ?

Wait shape is processed by SLA Agent, you can also check queue instances to see if it has been processed and if there were any errors.

May 12, 2016 - 3:26am
Response to rawap

>> Yes ..Case is configured with Default Locking.

>> Case is not locked.

we don't see errors in broken process.

May 12, 2016 - 8:22am
Response to Brahmesh@

Configurations:

Below is  the starting flow for the work object.

Wait shape configuration:

Still the case is staying at "wait" action after deadline is passed, instead of process the flow to advance.

I don't see any issues in service level queue.

May 16, 2016 - 5:21am
Response to Brahmesh@

I did same configuration in 7.2 version but it's not working .

Anybody had this issue ?

August 30, 2016 - 7:08am
Response to Brahmesh@

Hi Brahmesh,

Is this issue fixed. We are also facing the same issue. Could you please let us know the solution if any found.

 

Thanks,

Shalini Kopuri

Pega
May 22, 2016 - 3:11pm
  • we noticed the same issue
    • I assume that the task will be queued by the time we specify on wait shape
      • and the processing would depend on first in first out of queue list which could be consuming time...
        • anyone please weigh-in on my understanding as we often notice SLA firing late.

also as Pankaj Rawal said - please double check if the agent 'ServiceLevelEvents' is enabled on the system.

June 22, 2017 - 9:57am

Hello ,

If anyone has resolved this issue ,please let me know . 

Thanks 

July 30, 2017 - 11:03am

Hi , Any update on this issue .I am also facing the same issue and waiting for solution.

 

Thanks

Dasaradha

Mod
July 30, 2017 - 11:13pm
Response to DasaradhaReddyP

Hi Dasaradha,

Since this post is not recent, we are are not sure if this will be updated by the original poster. Here are 2 Support Articles I found over PDN which looks to be related: 

Wait shape is not waiting for the time-interval configured 

Wait shape not waiting for all cases to be resolved

In case, these do not help you, please create a new post by clicking Write a Post button present on the top right of this page.

Regards,

Lochana | Community Moderator | Pegasystems Inc.

September 25, 2017 - 5:03am

Hi Brahmesh,

if it is taking exactly 15 miniutes to continue the process, then it is default behaviour of Queue(SYSTEM-QUEUE-SERVICELEVEL).Please check the attachment this can be helpfull.

Thanks,

Hussain

August 17, 2018 - 3:55am

Hello,

I read your attachment and we have exactly the same problem but I don't understand : 

"Reason: If the System queue contains more cases in queue, then by default pega will give 15 min for wait. If queue is not having much case, then after 1 minute system will continue from wait shape."

Just: why ? You mean if there is more than one item in the queue, Pega will dequeue all of them 15 minutes later ?  Why ? 

Thanks,

Orianne

August 17, 2018 - 5:27am

HI Brahmesh,

We faced similar issue so can you try using SLA.

if you want sla configuration i will provide you.

August 20, 2018 - 7:11am

Have you tried whatever i suggested above?

August 20, 2018 - 12:59pm

What do you mean by using SLA ?

August 21, 2018 - 2:49am
Response to PatrickM1883

can you try to add SLA in sla after reaching goal you can run activity in which you can do resume flow.

August 22, 2018 - 3:44am
Response to Gayatri

Hum, I'm interested in the SLA configuration you are talking about.

August 22, 2018 - 4:22am
Response to PatrickM1883

so can you try using SLA and revert back to me if u need any help.

August 31, 2018 - 2:35am
Response to PatrickM1883

HI have you tried ?