Question

WAIT Shape not progressing even though the time interval has reached/passed

Hi,

I have a requirement to add a delay before progressing to next step.

I have tried to use the following methods, but non of them progres to next steps when the time interval reached/passed. Only manual trigger by pressing 'Stop waiting and progress' button can move the flow go through. Need help to configure this delay task correctly so it will auto move to next flow once time interval reached/passed.

Thanks a lot in advance for help. Attached are screens of the flow and configuration that I have tried.

1. Use WAIT Shape

  • Added a WAIT shape in between 2 shapes (refer to waitShape.png)
  • Update property of the WAIT shape to wait for certain amount of period before proceed to next step. (refer to waitShapeProperty.png)

2. Use Assignment Shape with SLA

  • Added an assignment shape in between 2 shapes (refer to assignmentShapeToDelay.png)
  • Update the workbasket to designated workbasket for the application (refer to assignmentProperty.png)
  • Update the SLA,
  • Action assigned is ‘Advanced Flow’, and flow action to go to is ‘pyContinueAfterWait’ (refer to advanceFlow.png)
  • Assign same action to the SLA on:
    • Goal
    • Deadline
    • Passed Deadline

***Updated by moderator: Lochan to update Categories***

**Moderation Team has archived post**

This post has been archived for educational purposes. Contents and links will no longer be updated. If you have the same/similar question, please write a new post.

Comments

Keep up to date on this post and subscribe to comments

January 8, 2017 - 10:38pm

Hi Alex,

Configurations at scenario 1 Use Wait shape looks fine, there can be 2 reasosn for failure

1. Ensure ProcessFlowDependencies agent is running

2. Check router to setting at Customer Questionnaire assignment, it will fail if the selection is 'current operator' because in both scenarios an agent perform the process so it fail to route System operator.

September 25, 2017 - 5:00am

Hi Alex,

if it is taking exactly 15 miniutes to continue the process, then it is default behaviour of Queue(SYSTEM-QUEUE-SERVICELEVEL).Please check the attachment.

 

Thanks,

Hussain

August 21, 2018 - 6:13am

Can you try the same using SLA ?

I