Question

Validate Error Visible

Hello
To check the input I use Edit Validate rule.
When entering erroneous data error does not appear.
I set up an Action Set, in which, by changing the value (Event - Change), I use Action "Post value", an error appears, but if I click on the field and remove the cursor from it (without changing the field value, the error disappears from the user's form (in the clipboard displayed)
How to make it so that the error is always displayed?

Comments

Keep up to date on this post and subscribe to comments

Pega
June 17, 2019 - 12:00am

Hello,

Can you confirm if the "Always show error" checkbox for the harness has been enabled? Additionally do let us know the version of Pega you are using.

You could check the below article as well:
https://community.pega.com/support/support-articles/errors-flash-and-disappear-screen

June 17, 2019 - 10:02am
Response to Evita_08

Hello
Both checkboxes are selected in the Harness setting, but the error still disappears when you click on the field again and leave

Pega
June 17, 2019 - 11:55pm

Hello,

Can you try defining a Refresh-Section along with Post value? Can you also add screenshots for how the section is designed which consists the text input? Just want to clarify if the field is inside a dynamic layout or in a grid layout.

 

 

June 19, 2019 - 4:54am
Response to Evita_08

Hello,

The problem appears when leaving the field without changing the value, and in the standard set there is no “leaving the field” event close to this “Change”, but there is no change
The field is with other fields in Dinamyc Layout.

July 4, 2019 - 2:45am

Hi,

Could you please confirm whether you are facing the same issue as in the below Article with same version mentioned(7.2.2):

https://community.pega.com/support/support-articles/field-validation-error-message-does-not-display

Thanks,