Question

Unable to Start Interrogation

Hi,

I was trying to start interrogation for a web application, however, i was getting below error, any idea how to fix it?

1) Exception Information
*********************************************
Exception Type: System.NullReferenceException
Message: "Object reference not set to an instance of an object."
Data: IDictionary (System.Collections.ListDictionaryInternal) with 0 items
TargetSite: System.String GetInternetExplorerPath()
HelpLink: NULL
Source: "OpenSpan.Common"
HResult: -2147467261

StackTrace Information
*********************************************
at OpenSpan.Common.Utils.InternetExplorerHelper.GetInternetExplorerPath()
at OpenSpan.Common.Utils.InternetExplorerHelper.GetInternetExplorerVersion()
at OpenSpan.Adapters.Web.WebAdapter.StartAdapter()
at OpenSpan.Adapters.Adapter.HandlePerformStart(Object sender, CancelEventArgs e)
at OpenSpan.Design.DesignComponentCommon.OnPerformStart()
at OpenSpan.Design.DesignComponentCommon.Start()
at OpenSpan.Design.DesignComponent.Start()
at OpenSpan.Adapters.Design.InterrogationService.StartInterrogation()

***Edited by Moderator Marissa to update platform capability tags****

Comments

Keep up to date on this post and subscribe to comments

April 2, 2019 - 12:41pm

Already tried to re-install the studio, but it's still not working...

April 8, 2019 - 8:20am

Same problem here. Did you find a solution?

April 9, 2019 - 9:36am

Hi Randy, if you get this issue, there may be a problem with your security settings for IE, also try adding that site to you compatibility view under the Tools tab in IE. This should solve your problem. You also want to be sure that the StartPath property of your WebApplication is set to a url so that the bot knows what page to load and where it should begin its interrogation.

April 10, 2019 - 10:19am
Response to NiaC0459

Hi Nia,

Thank you for your response, may I know if what particular security setting i should change in IE?

April 10, 2019 - 11:12am
Response to RandyC07

Yes, Randy, the settings would really depend on your current IE settings, however, the quickest way to see if this is in fact the issue is to open internet options of IE and change the Security settings. Enabling more options seems to usually help.

October 12, 2019 - 9:26am