Question

Unable to see methods in script component (8.0.1080)

We are not able to see the methods in the script component to drag into automations, also unable to edit the parameters for existing methods.

We have tried

*moving script to Local/Global in automation and also Global container.

* Building/cleaning/validating script and project.

* replacing references to the project

No methods available in configure type to drag in automation (both for existing and new scripts).

The script component is working fine in another project in the same computer. Please advise.

***Edited by Moderator: Lochan to add SR tag***

Group Tags

Correct Answer
July 26, 2019 - 6:35am

We identified that the ‘.’ in the existing solution/project names were causing this unexpected script-method-unavailable behavior in 8.0.1080.
We were successfully able to rename all the solution/project reference names in 1080 studio projects by removing all the ‘.’ and then performing a clean-build solution
Hope this info helps!

Comments

Keep up to date on this post and subscribe to comments

July 19, 2019 - 12:43am

Try by closing and open the pega studio and delete the project from %appdata% (go back to local)->openspan->8.0->projects

July 19, 2019 - 1:15am
Response to Jayachandra Reddy K

Thanks for the update!

I tried by deleting all the files from C:\Users\shashkum\AppData\Local\OpenSpan\8.0\Projects folder and performed clean-build-validate, but still no luck !

 

July 19, 2019 - 7:21am

Try as below.

Add global container and script component, now add one method and build it. Check if method is visible or not? If still not seen, close script window, global container window and check again.

July 19, 2019 - 10:47am
Response to Jayachandra Reddy K

Hi Jayachandra,

Thanks for the response. We tried the above steps already but we don't see the methods in the project.

Note: There is no issue in other projects and new projects, only in one project.

 

July 26, 2019 - 6:35am

We identified that the ‘.’ in the existing solution/project names were causing this unexpected script-method-unavailable behavior in 8.0.1080.
We were successfully able to rename all the solution/project reference names in 1080 studio projects by removing all the ‘.’ and then performing a clean-build solution
Hope this info helps!

Mod
July 26, 2019 - 6:53am
Response to RanjithThomas

Thanks for updating the solution back here! We will mark with post as Answered.

Lochana | Community Moderator | Pegasystems Inc.