Question

Unable to obtain session. Cassandra hasn't been started or is unavailable.

Hello! In my Pega 8.3 application, when I start it up, I get the following errors w/ Cassandra.

[service: VBD.Default] [ STANDARD] [ ] [ ] (rvice.operation.StartOperation) ERROR - Cannot start service [VBD.Default]. Will retry in 180 seconds. Remaining attempts: 2
com.pega.dsm.dnode.api.dds.service.SessionNotAvailableException: Unable to obtain session. Cassandra hasn't been started or is unavailable

Caused by: com.datastax.driver.core.exceptions.NoHostAvailableException: All host(s) tried for query failed (tried: /XXX.XXX.XX.XX:9042 (com.datastax.driver.core.exceptions.TransportException: [/XXX.XXX.XX.XX:9042] Cannot connect))

How can I fix this error and get a clean log file? Via a DSS setting?

Thanks!

***Edited by Moderator Marissa to update platform capability tags****

Comments

Keep up to date on this post and subscribe to comments

August 22, 2019 - 6:37pm

Can you attach the cassandra log and also the PegaRULES log which DDS was supposed to be started?

August 23, 2019 - 8:23am
Response to WaikeiKwok_GCS

The log files are attached.

August 22, 2019 - 7:50pm

what is your -DNodeType JVM setting? If you only want this node to be web node, use -DNodeType=WebUser. It is likely that your -DNodeType=Universal, which will try to start all decisioning services. If you indeed want all decisioning services to startup (which should only be used for non-production env), check if any firewall is enabled that prevents port 9042 from communicating.

August 23, 2019 - 9:18am
Response to KevinZheng_GCS

You are correct that I was using the -DNodeType=Universal. I was able to change that as you suggested and restarted. The Cassandra error went away. I'm working with my networking folks regarding the firewall for port 9042.