Question

Smart Info in repeating layout is not working in ios (Iphone)

1) Add Repeating layout to a section and configured the page list property..

2) Refer a section in repeating layout which contains a link/icon to display the smart info on click.

After click on smart info icon of the second record then whole page is getting wiped off . (Attached the snapshot)

No issue in Desktop and Android devices.

if page list has single record then there is no issue . The Issue is happening with repeating layout which displays multiple rows.

Below article might be related to similar behaviour but there is no resolution.

https://community.pega.com/support/support-articles/smart-info-does-not-display-mobile-device-resolution

Pega 7.3.1

***Edited by Moderator: Lochan to update platform capability tags***

Group Tags

Comments

Keep up to date on this post and subscribe to comments

Pega
October 23, 2019 - 9:19am

Hi Brahmesh,

Can you trying adding a hidden text control in the section and configure the same smartinfo action set on that control. 
Also refer the below link:
https://community.pega.com/support/support-articles/smart-info-does-not-get-displayed-hover
 

October 23, 2019 - 10:14am

Looks to be the same root cause. The support article says issue happens because the link to which the smart info was present on the DOM twice.

In your use case as well, the issue happens *ONLY* when RDL contains more than one record.

Of course, the solution in the SA wont work for your use case since the link is repeated via a RDL.

Check if you can introduce pagination to limit the number of records -- just a diagnostic to check if it helps with the problem. I would suggest opening a SR to get this evaluated.

October 24, 2019 - 4:39am

SR-D55556 has been raised