Question

SLA for ExecuteProgramRun flow in marketing not triggering the expecting log message

I have a requirement to log message if the executeProgramRun flow does not complete with in a specified time . I am not sure if SLA given in the flow is picked up and I am unable to trace the requestor thread. Also the log message is not seen anywhere in the log files. Need your expert assistance.

***Edited by Moderator Marissa to update SR Details***

Group Tags

Comments

Keep up to date on this post and subscribe to comments

Pega
August 15, 2018 - 8:36am

Hi,

In order to provide assistance some more information is needed.  Can you please explain further what you mean by 'I am not sure if SLA given in the flow is picked up'?  Have you customized the 'executeProgramRun' flow?  Also,  please indicate what version of Pega Marketing and Pega you have installed.

Some more information about the use case requiring logging the message would be helpful too.  Logging a message doesn't seem like the most effective mechanism for communicating this information.

Thanks,

Amy

 

August 16, 2018 - 12:17am
Response to ROHEA

The problem statement is to trigger an alert when a campaign is not completing with in a stipulated time . So the design which I could think of was to customise the ExecuteProgramRun flow and include an SLA in the design  which I am not able trace or confirm if its being executed. that is what I am trying to convey in 'I am not sure if SLA given in the flow is picked up'? . Please let me know if you have a better approach to achieve this requirement.

August 15, 2018 - 10:46am

August 31, 2018 - 1:01am

HI,

I am finding it difficult to trace the requestor session as it throws some local host error. Any idea how to identify if the SLA is invoked?

September 11, 2018 - 7:25am

Can anyone help me with this query please? I tried tracing the SLA but am not able to . Is there any way to establish the functionality?

Pega
September 14, 2018 - 4:21pm

Hi, 

Could you explain in a bit more detail how you will use this log data.  Is the intention to monitor campaign performance by reviewing the logs for these messages?  Or is there a plan for some action to be taken when the log entry is recorded?  Having an understanding of the goal could help us provide more assistance.

Starting in Pega Marketing 7.31 there are some extension points available in the ExecuteProgramRun flow.  If possible it would be advisable to use these instead of overtaking the flow itself. 

What version of Pega Marketing are you using?

Thanks,

Amy

September 18, 2018 - 1:10am
Response to ROHEA

We have a requirement to trigger an incident /notification if the campaign does not completed with in the prescribed time. There is a Tivoli system which will listen to PegaRules.log file for configured alerts and raise an incident depending on the alert.

For now the design that I have thought of is to write a log-Message in the SLA activity, which would in turn be read by the external system.

Version of Pega marketing -7.31

Please let me know if any of the available extension points would help complete this requirement.

October 3, 2018 - 12:35am

I had raised an SR parallely and found that this issue exists only with ExecuteProgramRun flow .

October 3, 2018 - 2:04am
Response to DivyaV19

Hi @DivyaV19 ,

Do let us know the SR number so that we can connect the post to the SR and the troubleshooting is concentrated at a single place.

Thanks!

Vidyaranjan | Community Moderator | Pegasystems Inc.

October 3, 2018 - 2:17pm

Hi @DivyaV19,

I found the SR you opened and linked this PSC post to it and notified the Engineer working it.

Let us know the resolution when you reach one!

Thanks!

Marissa | Community Moderator | Pegasystems Inc.

October 4, 2018 - 12:14am
Response to MarissaRogers

Thanks Marissa. Will do , once we arrive at the resolution.

December 26, 2018 - 1:54pm

Hi @DivyaV19!

I see that your Support Request has been resolved  and that you were asked to check all of the node logs to see the log messages.

Did that resolve this for you?

Marissa | Community Moderator | Pegasystems Inc.

December 27, 2018 - 12:48am

Yes Marissa, i am in the process of verifying the solution provided. will keep this thread posted . We have a dev rebuild scheduled in the first week of Jan , will confirm the SLA issue after the rebuild 

December 27, 2018 - 9:07am
Response to DivyaV19

Sounds good @DivyaV19! Looking forward to hearing how it goes!

Marissa | Community Moderator | Pegasystems Inc.