Question

Security question - Set secure cookie

Hi Team,

Our application had undergone security test and they found issues related to cookie. Please find below risk

If the secure flag is set on a cookie, then browsers will not submit the cookie in any requests that use an unencrypted HTTP connection, thereby preventing the cookie from being trivially intercepted by an attacker monitoring network traffic. If the secure flag is not set, then the cookie will be transmitted in clear-text if the user visits any HTTP URLs within the cookie's scope. An attacker may be able to induce this event by feeding a user suitable links, either directly or via another web site. An attacker with sufficient network access could eavesdrop network traffic to capture these, then use them to hijack the user's session

Recommendation : We recommend enabling the secure and HttpOnly flags on the affected cookies

solution tried : created below DSS

prconfig/http/setsecurecookie/default and set to TRUE

prconfig/cookie/httponly/default and set to TRUE.

Issue : after setting this, we are not able to login to pega designer studio, could see below errors in log.

Error in log :An error has occurred which indicates that your browser does not support Cookies. You must enable Cookies in order to use this application

Please recommend here

Comments

Keep up to date on this post and subscribe to comments

May 23, 2019 - 10:51am

Hi,

Are you logging in over http or https?

Were any other settings added along with the one's above?

Pega
May 23, 2019 - 10:53am

Hi,

Is the URL you are using to access the system start with http:// or https://.   When you set secure cookies that means you can only use a https:// address to access the system. 

Make sure there are no proxies etc taking https:// to http:// either. 

--Chris

 

 

July 19, 2019 - 3:51pm

we are accessing https and made sure that no proxies etc taking https:// to http. but still issue is arising during pen test. 

PFA, request and response as proof of concept.