Question

Runtime Performance Issues while Running Solution Developed for Java Swing application In Pega Robotics Studio v 8.0.1080

Hi

I have developed a Project/Solution for automating java desktop based swing application 1.8V ,when am running the solution (which is working fine in v1058) in v1080,i have encountered below performance issues,

1)first of all solution is not working during runtime ,it takes a lot of time (which is not constant) in identifying & failing to perform methods (like performclick ) on come controls(javax.swing.JButton,javax & some menu items inside javax.swing.JMenuBar),some times throw particular control not matched error or else it will throw Error "CVirtualJavaBroker::InvokeReceived: Exception invoking method GetCountEx on object with id 18 " or else it will get stopped in middle

2)Solution works fine when testing with breakpoints by step Into F11

3)Sometimes the same solution works fine in other environments like DEV it is not taking lot of time in identified by the OpenSpan (the time it takes in other environments) but everyone it works only by putting breakpoints without breakpoints it is not at all working.

We have tried increasing more sleep time or delay (more than 30 mins) in WaitForcreate method & in Pause stage. Also tried recreating whole solution from scratch & applied match rules for failing controls but still no luck.

but we never faced this issues when running the same solution in v1058.

Are there any specific java swing application Translators Or UIConnectors available or Through Create Type Extension /Component Extension can we solve these issues?

We even had WebEx call with Pega Support Executive (SR-C26122) ,but the executive had asked us to share log files which we are not supposed to share because of compliance issues & policies.

So I request if anyone faced the same issue & had any resolution step ,please kindly provide some solution or advice as it is very emergency to get resolved.

Regards,

Pravallika.

***Edited by Moderator Marissa to update SR Details***

**Moderation Team has archived post**

This post has been archived for educational purposes. Contents and links will no longer be updated. If you have the same/similar question, please write a new post.

Group Tags

Comments

Keep up to date on this post and subscribe to comments

April 16, 2018 - 8:21am

Hi Pravallika,

I am woring with the studio v7.1.63. 

I am aslo facing same problem,

But i am using try- catch Solution to perform click( ), Well it's clicking but error remains the same!!.

pls find the Screen shot ofr the same issue

    

 

Pega
April 18, 2018 - 11:08am

Hello Pravallika,

This issue sounds like something that should be handled through an SR (and will be extremely difficult to fix without any type of logging). Is SR-C26122 the correct SR? It does not seem related to the behavior you are describing here.

At a glance, this could be cause by antivirus or security settings at an environmental level (As this only happens on certain machines), but it will be difficult to determine. This also seems timing related (since it works when stepping through it) but giving you steps to resolve will be difficult to do here, an SR through a support engineer is where issues like this should typically be worked on. 

May 7, 2018 - 2:55am
Response to heffc

The correct request no-SR-C26122 for the issues which were facing ,now this errors I stated were coming in the code (developed & working fine in 1058) while running in 1080 , we again recreated code form scratch in Pega robotics Studio 8.0.1080 ,now there are no errors but performance of automation  is very slow than earlier it was very fast when we develop & ran the code in 1058,we cant share the log files as per the client governance & compliance policies.

Pega
May 9, 2018 - 10:45am
Response to PravallikaM465

Hello,

I still do not believe SR-C26122 is the correct SR for this issue, as that SR is about reaching a Pega Platform website and has nothing to do with Java Swing applications or Pega Robotics.

That said: Have you investigated the antivirus or security possibility and tried whitelisting the Pega Robotics install folder? If that does not work it will be near impossible to solve this without any sort of logging as we will not be able to see why/how this is happening. Again, I am still of the opinion that the SR is the best place to work on this, but even then, getting any sort of resolution when we cannot extract any information will be near impossible.

July 12, 2018 - 11:23am
Response to heffc

Hi,

We have exactly similar issue. I have raised an Support Request SR-C45935 for this and shared the screenshot and log file.

I believe that the core issue is the Robotics is taking way too long (at times more 2 mins) for either for matching the control or unable to identify the created control.

 

I didn't get what whitelisting the pega robotics install folder means.. can you please elaborate more on that.

 

Thanks,