Question

RPA Scheduling Service not terminating the BOT

Hi All - Need help from someone who is using Pega RPA Service to schedule unattended BOTS. We upgraded our studio and runtime version from 8.0.1110 to 8.0.2030 and installed the Pega RPA Service to control the schedule using schedule.json file. Pega Auto Logon service is able to login to the BOT machine in the specified time in the scheduler file but it is not able to terminate the BOT even after the specified duration and it is processing the cases even after the scheduled end time is past. Settings in the RPA service.config file is also set as "Scheduled" so that the service reads from the scheduler.json file. We are using Pega 8.2.2 and Robot Manager 8.2.

Steps to Reproduce

1. Set the start time and duration in minutes.

2. Assign the BOT to process the cases

3. BOT doesnt terminate and log off from the machine even after the end time mentioned in the scheduler file is reached.

Error Message

None

Attempted Solutions

Restarted the Pega RPA Service from windows services and modified the schedule multiple times. Still Pega Robot Runtime doesnt

detect that the schedule has ended and continue picking the cases

Can someone please throw a light on this issue? We followed all the steps mentioned in the below articles but still no luck!! Any quick help is greatly appreciated and our upgrade is at a standstill

https://community.pega.com/knowledgebase/articles/pega-robotic-automation/rpa-service-processing-flow

https://community.pega.com/knowledgebase/articles/pega-robotic-automation/installing-pega-rpa-service

https://community.pega.com/knowledgebase/articles/pega-robotic-automation/scheduling-when-robotic-process-automation-robot

***Edited by Moderator: Lochan to add SR tag***

Group Tags

Comments

Keep up to date on this post and subscribe to comments

Pega
October 1, 2019 - 9:08am

Given your thorough description, it sounds like you may have identified a bug. I would suggest that you check that your RuntimeConfig.xml has the following setting in the Shutdown section; the Behavior value key is set to WaitForAutomations. If that is set to Immediate, then perhaps the shutdown is getting stuck and it is simply picking up the next item.

October 2, 2019 - 6:12pm
Response to tsasnett

Yes it is a BUG as confirmed by the tech support. We did have the "WaitforAutomations" property set and BOT still continued to pick cases. If we set the property to "Immediate" , scheduler was killing the runtime abruptly at the specified time without letting the automation to complete which is not ideal. Currently the ticket is assigned to engineering team and we are waiting for further updates.