Question

Replacing PromptSelect with pxDropDown is not working in DataTableEditorReport

We are upgrading from 7.3.1 to 8.3. There are some properties where we had used PromptSelect. We are now trying to replace that with pxDropDown. This property is used in DataTableEditorReport. So when we try to add a row in a data type, where the property is used the drop down doesn't show.

I also stumbled across an article which says virtual grid only supports Non Auto generated controls. Just assuming if that is the reason PromptSelect works and pxDropDown doesn't in DataTableEditorReport. Could anyone please suggest?

Thanks!

***Edited by Moderator Marissa to update platform capability tags****

Comments

Keep up to date on this post and subscribe to comments

Pega
December 3, 2019 - 1:12am

Hi,

The prompt select control has been deprecated in 8.3 version and it is replaced by dropdown.

Just to get a clarification, are you referring the property in the report or are you trying to add the property in the data type?

I tried the use case and I am able to see the results when i run the report.

Hope my understanding is correct!

Thanks,

December 3, 2019 - 2:56pm
Response to mutha1

HI, 

I am using the property in DataType. When I tried adding a row the drop down doesn't show with pxDropDown. Could you please try this?

Thanks! 

Pega
December 3, 2019 - 10:43pm
Response to RESHMI406

Hi,

I have tried to add the property in the data type. And are you mentioning about the type that has been selected in the data type :

December 4, 2019 - 12:14am
Response to mutha1

HI, I am talking about the type of control in the property rule TestData (in your example). Use pxDropDown there instead of PromptSelect.  

Then add a row in the datatype to insert value.

Thanks!

December 4, 2019 - 9:26am

How have you configured the pxDropDown. Is it populated from a Data page that contains these values ?

December 4, 2019 - 2:45pm

HI Krithiga, As provide screenshots above I have configured the pxDropDown with local list replacing the PromptSelect. (PropertyName: Process Step)

Thanks!