Question

Remote tracer from Requestor Management shows blank page

I am facing an issue with the remote tracer option available in Requestor management page. When a user clicks on the tracer option then it shows "Web page cannot be found error".

Is there any configuration change cause this kind of issue? Its working fine with other applications in the same environment. Pega version 7.3

Please provide inputs. Thanks.

Correct Answer
October 30, 2019 - 11:04am

The problem identified and it was due to flaw in Tomcat 8 which restricts the Access Group code which has special characters.

To fix this issue you need to add the below configuration in the server.xml file of your tomcat server,

<Connector port="8080" protocol="HTTP/1.1" connectionTimeout="20000" redirectPort="8443" relaxedQueryChars="[ ]" relaxedPathChars="[ ]" />

Restart server.

 

 

Comments

Keep up to date on this post and subscribe to comments

October 25, 2019 - 2:42am

Hello, 

Do you have the same behaviour if you open the tracer normally and change the requestor from there?

October 28, 2019 - 1:45pm
Response to MarcLasserre_GCS

No, It works fine with the above-mentioned change.

October 30, 2019 - 11:04am

The problem identified and it was due to flaw in Tomcat 8 which restricts the Access Group code which has special characters.

To fix this issue you need to add the below configuration in the server.xml file of your tomcat server,

<Connector port="8080" protocol="HTTP/1.1" connectionTimeout="20000" redirectPort="8443" relaxedQueryChars="[ ]" relaxedPathChars="[ ]" />

Restart server.