Question

React Starter pack

Hi, Anybody used react starter pack. Can you please explain the steps to use it on localhost

https://community1.pega.com/exchange/components/react-starter-pack

Correct Answer
September 18, 2019 - 1:28pm

Can you change the CORS filter parameter "cors.allowed.headers"  in your web.xml to match the following and let me know?

<init-param>
    <param-name>cors.allowed.headers</param-name>
    <param-value>If-Match,access-control-expose-headers,Authorization,Content-Type,X-Requested-With,accept,Origin,Access-Control-Request-Method,Access-Control-Request-Headers</param-value>
</init-param>

Comments

Keep up to date on this post and subscribe to comments

Pega
January 30, 2019 - 6:10am

Hello

i see this is an exchange component. For queries on this, it is better if you contact the owner of the component. 

@ISSAS can you please help.

February 20, 2019 - 10:51am

@ISSAS can you please help

Pega
February 20, 2019 - 4:12pm

Please follow the "## Custom Configuration" in README.md. Also make sure that you have configured CORS for your Pega application server. Here is how to configure CORS for Tomcat: https://tomcat.apache.org/tomcat-8.0-doc/config/filter.html#CORS_Filter

If you want to point the application to a different server follow these steps:
 

* Open `PegaApp/src/_services/endpoints.js` and modify the BASEURL field to your desired system.

* Ensure that your desired application includes the ruleset Pega-API:08-01 (or higher).

* Ensure that your access group includes the PegaRULES:PegaAPI role.

September 17, 2019 - 11:40am
Response to ISSAS

Hi I installed personal edition 8.3 and when i imported cable connect RAP into Application tried to user ReactStarterPack813 after changing web,xml in web-inf and in tomact conf folder still iam facing issue as below:

Failed to load resource: the server responded with a status of 403 ()
login:1 Access to XMLHttpRequest at 'http://localhost:8085/prweb/api/v1/authenticate' from origin 'http://localhost:3000
has been blocked by CORS policy: Response to preflight request doesn't pass access control 
check: No 'Access-Control-Allow-Origin' header is present on the requested resource.

 

i added filter settings as below

  1. <filter>
  2. <filter-name>CorsFilter</filter-name>
  3. <filter-class>org.apache.catalina.filters.CorsFilter</filter-class>
  4. <init-param>
  5. <param-name>cors.allowed.origins</param-name>
  6. <param-value>*</param-value>
  7. </init-param>
  8. <init-param>
  9. <param-name>cors.allowed.methods</param-name>
  10. <param-value>GET,POST,HEAD,OPTIONS,PUT</param-value>
  11. </init-param>
  12. <init-param>
  13. <param-name>cors.allowed.headers</param-name>
  14. <param-value>Content-Type,X-Requested-With,accept,Origin,Access-Control-Request-Method,Access-Control-Request-Headers</param-value>
  15. </init-param>
  16. <init-param>
  17. <param-name>cors.exposed.headers</param-name>
  18. <param-value>Access-Control-Allow-Origin,Access-Control-Allow-Credentials</param-value>
  19. </init-param>
  20. <init-param>
  21. <param-name>cors.support.credentials</param-name>
  22. <param-value>true</param-value>
  23. </init-param>
  24. <init-param>
  25. <param-name>cors.preflight.maxage</param-name>
  26. <param-value>10</param-value>
  27. </init-param>
  28. </filter>
  29. <filter-mapping>
  30. <filter-name>CorsFilter</filter-name>
  31. <url-pattern>/*</url-pattern>
  32. </filter-mapping>

kindly help me in this.

Pega
September 18, 2019 - 11:50am
Response to Venkatesh.Vinnakota

Hi  Venkatesh, your server CORS settings are not configured properly. Things to check:

Did you add your CORS filter from above to web.xml?

Did you restart the server after?

Is your Pega Endpoint-CORS policy mapping configured properly?

September 18, 2019 - 12:25pm
Response to ISSAS

Please find attached web.xml this is the one i changed in webapps /prweb

Is your Pega Endpoint-CORS policy mapping configured properly?-- i didn't get what you are referring regarding DSS i checked three DSS they are fine as mentioned in PEGA help.

 

yes i shotdown application after making changes and restarted My Personal Edition. Still Facing The Issue..

Pega
September 18, 2019 - 1:28pm
Response to Venkatesh.Vinnakota

Can you change the CORS filter parameter "cors.allowed.headers"  in your web.xml to match the following and let me know?

<init-param>
    <param-name>cors.allowed.headers</param-name>
    <param-value>If-Match,access-control-expose-headers,Authorization,Content-Type,X-Requested-With,accept,Origin,Access-Control-Request-Method,Access-Control-Request-Headers</param-value>
</init-param>

September 19, 2019 - 3:26am
Response to ISSAS

Thank You very much.

Issue been Resolved Regarding CORS now i was facing different issue

"Pega_API_022: Use of TLS/SSL is required" when i remove authentication in service package i am getting 

TypeError: Cannot read property 'forEach' of undefined kindly help me in this. how to proceed request for http instead of https in personal edition

 

 

 

September 19, 2019 - 7:10am
Response to Venkatesh.Vinnakota

Hi @Venkatesh.Vinnakota -

Glad to know the original query is solved. I have marked the comment as answer on your behalf.

I read that you have a new question as well. I'd suggest you create a new post for additional questions. It ensures your new question gets the right visibility in the community. Here is a direct link to Write Post .

Thanks.

Vidyaranjan | Community Moderator | Pegasystems Inc.