Question

PyActivitypzZZZ parameter - any way to extract that value?

Hello!
I'm currently performance testing a PEGA based application on a non-prod environment, and I ran into some issues when SSL got implemented.

Now that we access the application through HTTPS, I'm no longer able to execute performance tests as most requests require a specific parameter (pyactivitypzZZZ).

However, I was not able to find that value anywhere in the responses. The only place I could find a reference to it was in the javascript files, but it seems it is an internal variable I was not able to access.

Is there any way I can get access to that value?

***Edited by Moderator Marissa to update categories***

Correct Answer
December 12, 2017 - 8:57am

Hi Max,

I would suggest that you run the performance test with the option disabled so the test will actually run: e.g. <env name="initialization/Urlencryption" value="false"/>

Comments

Keep up to date on this post and subscribe to comments

December 11, 2017 - 6:17pm

Hi Max,

The pyactivitypzZZZ​ signifies the value of the encrypted URL that is sent across the wire when the following settings are present:  

<env name="initialization/SubmitObfuscatedURL" value="required"/>
<env name="initialization/Urlencryption" value="true"/>

Did you run your prior performance tests with these settings enabled?  

December 12, 2017 - 6:21am

Hello,

No - when we executed previous performance tests on HTTP those settings were not available.

From a performance testing perspective, would it make sense to disable those mentioned settings? If there is no way to dynamically get that encrypted value, we are not able to execute performance tests.

Thanks!

December 12, 2017 - 8:57am

Hi Max,

I would suggest that you run the performance test with the option disabled so the test will actually run: e.g. <env name="initialization/Urlencryption" value="false"/>

December 13, 2017 - 1:38pm
Response to BradTainter_GCS

Thanks! I've removed that parameter and now we're able to performance test once again. Thanks for the help!

September 5, 2018 - 12:34am

Hi MaxG930,

How did you disable the below by adding header before each pyactivitypzZZZ request in Vugen(Loadrunner Tool)?

or

This is configuration change from Pega Application side.

<env name="initialization/Urlencryption" value="false"/>

 

September 11, 2018 - 12:45pm
Response to RamkumarG3637

Hi Ramkumar,

The setting <env name="initialization/Urlencryption" value="false"/> is applied on the Pega side to disable the URL encryption.  This might also be configured as a Dynamic System Setting.  Work with your developers to determine if and how the setting is applied and you can then turn it off for your test if needed.

August 21, 2019 - 5:09am

Hi,

I am also facing the same concern. Is this the only solution to resolve this issue ?

Kindly advice.

Thanks,

JK