Question

Pega Notification Manager Service does not start

Hello everybody!

I need to start Pega Notification Manager Service in order to run an automation that uses a Windows Application Adapter with StartandWait propery value. However, when I try to execute Pega.Robotics.Service.exe it appears the following error:"Unable to open private Shared Memory" (Screenshots are attached).

Do you know how I can solve this?

Thank you!

Comments

Keep up to date on this post and subscribe to comments

Pega
July 8, 2019 - 1:32pm

The service is designed to start on the startup of the machine. If it fails to start, it is can be a sign that something is blocking it from starting.

Traditionally, you can start the service from the Services.msc console and it should be okay as well.

It may also fail to start if you have installed the Pega Native Foundation anywhere other than the installation directory of Pega Robotics Studio/Plugin/Runtime. 

September 25, 2019 - 2:42pm

Mitchell & Pega Team,

Is there any way to debug what might be blocking this service from starting?

We have 2 HVDs (Studio SP1, 2025) which fail to start the service, both showing the same error as above when the executable is launched. (See attached)

On another HVD (Plug-In SP1, 2025) where the service is displayed, attempting to start it fails "Cannot find file specified". Viewing the properties of the service, it displays a path of <default install directory>\Openspan.Services.exe. That file, however, does not exist; only Pega.Robotics.Service.exe. We attempted to rename this executable, and saw a different error.

Any information would be helpful.

Pega
October 11, 2019 - 9:23am

I would suggest that you open a support request, as this is not something I have seen before. There must be something with your machine that needs to be identified. If you do open a support request, please report the number here and we can add the resolution into the post.