Question

Pega 8.2 Upgrade error

Hi All,

We were trying to upgrade pega from 8.1 to 8.2. While running the upgrade script, we are getting the below error and the installer is stopping. We have updated the value of bypass.pega.schema property in the setupDatabase.properties file and retried the upgradation but its throwing the same error.

Exception in thread "main" java.lang.RuntimeException: Problem during method invocation (main)
[java] at com.pega.pegarules.boot.internal.extbridge.AppServerBridgeToPega.invokeMethod(AppServerBridgeToPega.java:279)
[java] at com.pega.pegarules.pub.PegaRULES.main(PegaRULES.java:85)
[java] Caused by: com.pega.pegarules.pub.database.NonexistentTableException: Database-NonexistentTable rules.pr4_rule_connect_robot PegaRULES

***Edited by Moderator: Lochan to update platform capability tags***

Comments

Keep up to date on this post and subscribe to comments

August 28, 2019 - 8:15am

Are you performing in-place upgrade? Please attach the entire upgrade log. The referenced table is new to pega82 I wonder if the DDLs have been correctly applied - check the database if that table is created or not.

August 28, 2019 - 8:32am
Response to KevinZheng_GCS

We ar doing inplace upgrade. I verified in DB, the table is not present. Attaching the complete logs.

August 28, 2019 - 2:01pm

Quite odd here: you are upgrading to 8.2.3? but the codeset version points to 8.1.3 (codeset version should be 08-02-04) from the log. Is it possible you are using the wrong distribution image version?

bootstrap from Pega-EngineCode:08-01-04

September 4, 2019 - 12:51am
Response to KevinZheng_GCS

Sorry. We are upgrading from 8.1 to 8.2. 

September 4, 2019 - 12:55am
Response to KevinZheng_GCS

While verifying the sql files generated by the upgrade scripts, we found like some queries are missing. I am attaching the sql files generated. 

September 4, 2019 - 5:45am

Could you try running the generateddl script (with --action upgrade) and see if this generated the expected SQL?

September 10, 2019 - 3:33am

This was issue with the generated scripts. Now the issue is resolved and I was able to complete the upgradation process. But after the server restart, I am getting below error in the browser wwhen I tried to launch pega.

 

502 Bad Gateway: Registered endpoint failed to handle the request.