Question

OAuth 2.0 Token not getting generated

Trying to generate OAuth 2.0 token but its not getting generated.

Earlier it used to get generated.

Now getting this error.

Looks like Data-Admin-Security-OAuth2-AccessToken is not getting generated at all.

I am using postman and i am sending client_id, client_secret, grant_type=client_credentials and Content-Type = application/x-www-form-urlencoded as header.

{

"errors": [

{

"ID": "invalid_client",

"message": "Client authentication failed "

}

]

}

***Edited by Moderator: Lochan to update platform capability tags***

Group Tags

Correct Answer
November 29, 2019 - 11:28am

SR-D65002 exists already and fixed with local change. 

Comments

Keep up to date on this post and subscribe to comments

November 27, 2019 - 10:03am

Hi Sanjay,

Can you please share your configuration details, did you tried with postman to generate a token?

You can use JWT tool to extract the token and see those value.

I have done that configuration and worked.

Please let me know.

Regards,

Anandh

Pega
November 29, 2019 - 11:28am

SR-D65002 exists already and fixed with local change. 

Pega
December 1, 2019 - 2:10am

Hi,

As per SR notes, The root cause is configurations error, Rule form was not getting saved properly and authentication values were not taking from the downloaded certificate.
It got resolved by the following steps.
1. Try creating a new client and save the rule form. After saving the rule form click on view and download certificate.
2. After downloading the certificate, copy the credentials values for client_id, client_secret from the downloaded certificate.
3. After providing all the values and saving the rule form properly it worked fine and the user was able to generate the access token.

Thanks,

Abhinav
 
 

December 19, 2019 - 1:56am

with this will it re-create new client id & secret key ,

if so is there any way i can use the existing values since i do not want share the new values to the other parties