Question

Null Pointer Exception in Connect-Rest method

Hello

When I try to call in activity Connect-Rest method, I get the following errors.

In the Connect Rest rule, Test Connectivity works well and I get the expected result. Testing in PostMan also works correctly. Please tell me what could be the problem.

***Moderator Edit-Vidyaranjan: Updated images to remove proprietary information ***

Comments

Keep up to date on this post and subscribe to comments

November 14, 2019 - 9:25am

Hello, 

Can you check your logs? Maybe you can share the logs with us for analysis.

 

November 14, 2019 - 9:39am

The name of an activity is not visible from your screenshots.

But you could also put more lights on what's going on inside the java step by adding additional logging. You need to check out in your private ruleset the rule. Please refer the post:

https://community1.pega.com/community/pega-product-support/question/how-trace-java-step-activity

Pega
November 16, 2019 - 10:12pm

Hello,

Which version of Pega are you using? , can you please attach the logs.

Thanks

Pega
November 16, 2019 - 10:56pm

Hi Maxim,

Please find the below video which is helpful to debug the java steps in the activity.

https://community.pega.com/video-library/support-guide-debugging-java-activities-and-rule-utility-functions

Pega
November 17, 2019 - 12:21am

Hi,

Can you please share error stack trace present in pega rules log.If service works fine with postman then definitely there is some issue with pega-rest integration.Exact reason can be found by analysing logs.

Thanks,
Abhinav

November 18, 2019 - 2:16am

Hi ,
Step Page is "unnamed" , this may cause failure?

Thanks,
Bharathan.