Question

Not able to interrogate objects/controls in Windows Application.

Hi All,

I am working on WIndows Application. To interrogate that using Windows Adapter.The problem here is, the objects or controls not able to capturing or interrogating.When i am trying to interrogate the controls, MDI Client only interrogated(The controls, Tabs and Menu's having in the MDI screen not able to interrogating by the "BullEye").I tried from Windows tab also but there not listing the all controls(having in MDI Client) to create objects. From Windows tab and interrogation form i can able to create the obect for MDI Client(The screen which contain all controls) only.I did with Add Control Regions option, objects has created but not Matchrules created(showing green tick mark on objects in object explorer). In Runtime not identified and not set the values for that controls.

2.And one more request is,

I am trying to interrogate the controls (error message label and OK button) pop up box within same windows application. When i click anywhere on that popup with mouse that would be enabled and activate to take actions on that popup window and then we can click on that manually. When we click on somewhere other than popup window, that popup window will be disabled.

The problem is, we should click on Interrogation form and then drag and drop on control to interrogate or create object(here we are clicking other window so popup window becomes in disable mode). When i trying to interrogate controls on popup window that entire popup window not highlighted to interrogate even controls having popup window also not highlighted. I tried through Windows option also but not get results.

-->These problems have repeated for entire application.

Please give suggestions to overcome these issues.

Thanks,

Chinna.

***Updated by moderator: Lochan to tag SR***

Group Tags

Correct Answer
November 29, 2018 - 4:19pm

Upon reviewing the associated SR, I see that this was resolved by upgraded to Robotics Studio 8.0.1106.

Comments

Keep up to date on this post and subscribe to comments

Pega
June 21, 2018 - 12:41pm

June 21, 2018 - 10:04pm

Is this java application?

Are you seeing virtual controls tab after starting interrogation, if yes then you can create controls from here.

June 22, 2018 - 6:45am

Thanks Kurt and Jayachandra for you replies,

@Kurt, those two URL's are not useful to me to resolve my issue.

@JAYACHANDRA , I do not know about the technology but that was developed by the Binsoft company.

And for me not showing that Virtual Controls tab after starting interrogation.You can find in the attachment.

Not able to interrogate the controls and not able to create objects for controls in Windows tab also.

Please help me anyone.

Thanks

Chinna.

 

June 22, 2018 - 8:44am
Response to chinnaguru

HI All,

I thing my application was developed by Visual Basic 6.0.xx.xx saying based on the factory showing in object explorer.

When i start the interrogation, not showing Virtualcontrols tab and not able to interrogate by the bull eye. you can find in attached screen shot as the same.

please share your suggestions to resolve my issues.

 

Thanks,

chinna.

June 25, 2018 - 3:16am
Response to chinnaguru

HI All,

Any comments please??

 

Pega
June 25, 2018 - 5:25pm

You'll likely need some hands-on support to resolve. I would suggest you open an SR for that. If you do, please record the SR number here.

For getting started on your own;

VB Labels are not controls, so they cannot be interrogated. The only way to read the text is to use control regions. Make sure you enable GDI in the OpenSpan.ini and enter the exe name into the process list. If you cannot locate the controls on the Windows Controls tab, then Pega Robotics is not able to interrogate them.

I do not understand your second issue, so please provide a better explanation and I may be able to help.

June 29, 2018 - 5:29am
Response to tsasnett

Hi Sasnt, thanks for your response.

Yes, I have created SR i.e.,  SR-C43148 .

 

Thanks 

Chinna.

November 29, 2018 - 4:19pm

Upon reviewing the associated SR, I see that this was resolved by upgraded to Robotics Studio 8.0.1106.

Marissa | Community Moderator | Pegasystems Inc.

December 29, 2018 - 2:35am

Hi All,

I'm facing similar issue.

I'm working with windows application, able to interrogate only the window that launches on starting interrogation and tool bar of that application.And unable to interrogate the menu bar which is similar to menu bar of notepad application but for which Add menu items option helped in getting the controls.

The other windows, popups getting launched further are not getting identified by bull's eye.

I could not find Openspan.Ini file and able to find Openspan.Iniupdater application.Is this the one said above if not can someone please share the path and how to work with that.

Could someone please suggest how to proceed further.

Thanks,