Question

No Projects error when trying to integrate JIRA with Agile Workbench

I'm getting an error, "Jira Project Name: Project does not exist" after I click Begin Integration when trying to integrate Agile Workbench with our JIRA.

I tried some of the suggestions in the old post https://community1.pega.com/community/pega-support/question/jira-connector-agile-workbench-does-not-return-any-projects​, but none worked,

For the following suggestion on the old post:

2.) Navigate to pySetupApplicationIntegrationDetails rule --> Private Edit --> Save --> Discard. After this, my JIRA projects and versions appeared.

I do not have a Private Edit button on this rule. I am new to Pega, only about 3 weeks. We are trying to evaluate some of the tools in Pega.

Comments

Keep up to date on this post and subscribe to comments

February 1, 2019 - 9:01pm

Hi,

Trying to answer your query on private edit option:

To have rule check in, check out and private edit you need to enabled "Allow Rule check out" option on the security tab of operator rule and "Use check-out" option in security tab of the "Ruleset" rule.

So you will see check in and check out option.

Once another user has check in the rule and you want to update the same rule you will see private edit option.

Helpful read for you 
https://community.pega.com/sites/default/files/help_v731/procomhelpmain.htm#designer-studio/checkout-and-checkin/ds-private-rule-checkout-con.htm?Highlight=private%20edit

https://community.pega.com/sites/default/files/help_v731/procomhelpmain.htm#designer-studio/checkout-and-checkin/ds-performing-a-private-checkout-tsk.htm?Highlight=private%20edit

Thank You

 

February 5, 2019 - 10:48am
Response to Shekhar_Shubham

Ok, I got the Private Edit button and did the steps mentioned in the previous thread.  I now get a Project dropdown after hitting connect, but the dropdown is empty.  I have tried using my own Jira login name, admin, and admin@myorg.com.  I am using Pega Version 8.1.2.  I have attached a screenshot and the tracer log.

 

February 5, 2019 - 1:09pm

I got projects in the dropdown by using another person's Jira login id.  We had not created any versions in Jira, so I chose the Create new version option in the Version dropdown.  But got Jira Integration error.  Here is from the logs:                                                                                                                         2019-02-05 16:54:43,809 [  http-nio-80-exec-4] [TABTHREAD0] [                    ] [   FOIATest:01.01.01] (e.internal.ServiceMappingUtils) ERROR pega.gateway-imd.myorg.com|10.138.203.187|Rule-Connect-REST.Pega-Int-ProjMgmt-Jira.JiraProjectsCRUD name@myorg.com - Caught unexpected exception mapping inbound data: Exception occurred while mapping incoming response to .GetJiraWIParamResultsList 
2019-02-05 16:54:43,811 [  http-nio-80-exec-4] [TABTHREAD0] [                    ] [   FOIATest:01.01.01] (      internal.mgmt.Executable) ERROR pega.gateway-imd.myorg.com|10.138.203.187|Rule-Connect-REST.Pega-Int-ProjMgmt-Jira.JiraProjectsCRUD name@myorg.com - Exception
2019-02-05 16:54:43,811 [  http-nio-80-exec-4] [TABTHREAD0] [                    ] [   FOIATest:01.01.01] (nvoke.Rule_Connect_REST.Action) ERROR pega.gateway-imd.myorg.com|10.138.203.187|Rule-Connect-REST.Pega-Int-ProjMgmt-Jira.JiraProjectsCRUD name@myorg.com - com.pega.pegarules.pub.services.InboundMappingException: Exception occurred while mapping incoming response to .GetJiraWIParamResultsList 
2019-02-05 16:54:43,811 [  http-nio-80-exec-4] [TABTHREAD0] [                    ] [   FOIATest:01.01.01] (      internal.mgmt.Executable) ERROR pega.gateway-imd.myorg.com|10.138.203.187 name@myorg.com - Exception

February 6, 2019 - 2:30am
Response to KathyD79

So i did the JIRA integration and below are the steps I followed. Can you verify the steps?

February 6, 2019 - 1:46pm
Response to Shekhar_Shubham

Yes, We followed those steps.

February 7, 2019 - 1:46am
Response to KathyD79

I am not sure what might be going wrong here. Can you get the tracer? Once you click on create new version, run the tracer that time.
Might help. 

Also can you add screenshot of step you getting error. Also complete log stack trace, if the one you pasted before is not complete 

I hope you have given permissions to the user in Jira(the one you using in jira auth profile)

Pega
February 7, 2019 - 2:15am

The tracer logs you shared are hard to read. Can you please save the tracer output as the xml
(using save in the tracer)and share that here. 

February 7, 2019 - 1:25pm

The Jira version was created in Jira.  (See attached.)  And the version shows up in the Version dropdown.  (See attached.)  But still getting Jira Integration Error.  I have also attached the Tracer content that I turned on just before hitting the Begin Integration button.

Pega
February 7, 2019 - 3:25pm

I just went through the tracer logs you shared, Looks like your application has some ruleset related issues. Just try to save application rule independently and you will see some errors on application rule. Fix those errors first and then try to integrate application with JIRA.

February 7, 2019 - 4:46pm

Ok  I got it to integrate, I think.  Not sure what fixed it.  Went into some of the rules, and re-saved them.  Also changed Validation mode from Ruleset Validation to Application Validation on JiraIntegration Ruleset and saved.  I am having another problem where I can't create a story or bug in Agile Workbench, but I will create a new post if I can't figure it out.