Question

No activity entries on pr4_log_rule_usage

We are trying to report on table pr4_log_rule_usage and pr4_log_rule_usage_details, but there is no one single entry regarding activites, which according to help files from PEGA versions 5, 7 and 8 should, in theory, be there.

We have tested this in several environment form our applications in versions 7.2.1 and 8.1 and is the same behavior for all (see screenshot below).

I am thinking that maybe we are missing some configuration and that is why we do not get activities recorded in Log-RuleUssage.

Does anybody have an idea why we are not getting activity usage statistics in this table?

Comments

Keep up to date on this post and subscribe to comments

October 14, 2019 - 5:48am

RuleUsageAgent is truned on an all environments. We do have entries on the table, and recent ones but for all other rule type, activites are not listed at all.

October 25, 2019 - 12:04am
Response to RobertoB6828

So what happens here is this :

PR4_LOG_RULE_USAGE_DETAILS: Holds details of a daily snapshot of the rules assembly cache, which the system can scan later at the next system startup to pre-populate the rules assembly cache

From 7.x at least (maybe from 6.3.x) the assembly cache(app centric cache) only saves data for stream based rule with some dependencies and special cases. 

Since activities are of type activity the PR4_LOG_RULE_USAGE_DETAILS doesn't have activity type details , hence it will not have activity data.

The screenshot provided in the post you have added is from 5.x that's why it can create some confusion.