Question

Need to include values with comma in BIX CSV Extract.

I have below requirement.

Pega is getting JSON message and its getting stored in one of the clipboard property on pyWorkPage. As part of BIX extract (we are using CSV format for BIX extract), this JSON message also needs to be included in it. But since there are comma in JSON message, BIX extract is not getting generated properly. I need to include whole JSON message as single value in BIX exctract.

Has anyone faced this issue earlier. I am using Pega 7.3

***Edited by Moderator: Lochan to update platform capability tags***

Correct Answer
September 16, 2019 - 11:50pm

Yes Vikash,

We did same thing later. We are using ~ symbol as delimiter in BIX now and it solved the issue as well. :)

 

Thanks,

Girish

Comments

Keep up to date on this post and subscribe to comments

September 13, 2019 - 9:06am

Hi Girish,

 

As you have mapped the JSON response to a property and they are separated by comma, you can replace all commas with some other special character to separate the value (for example *, |,#, etc.).

This way when you generate the BX extract in CSV format all the values will be in one cell.

 

Regards,

Vikash

September 16, 2019 - 12:31am
Response to Vikash Karn

Hi Vikash,

Thanks for your reply. I think in this way I will have to inform other application who are going to use BIX extract that replace these keywords again with comma if they need exact same JSON message. I was looking some way so that I can use values in same column with comma itself.

 

Thanks.. :)

September 16, 2019 - 4:57am

Hi Girish,

As you are generating CSV file and by default it uses comma(",") as separator so i am not sure if same file can have all the property values separated and one particular property also with commas.

One more option that you can change the delimiter of BIX extract generated from comma to some other special character as a separator (for example |) using -l parameter and specify what character to use instead of a comma.

This approach would also need you to inform other application who are going to use BIX extract. But this approach will be easier as you only need to take care of parsing of values which will be based on "|" instead of ",".

 

Regards,

Vikash 

September 16, 2019 - 11:50pm
Response to Vikash Karn

Yes Vikash,

We did same thing later. We are using ~ symbol as delimiter in BIX now and it solved the issue as well. :)

 

Thanks,

Girish