Question

Need help getting started with PegaKM

I'm having issues using PegaKM and I could use some advice. How do I set up an appropriate access group? According to the user guide

It is a best practice to modify one of your Pega application’s System Administrator operator’s access group or create a new operator to include the KMPortal portal and PegaKM:Publisher role. The operator’s application rule should also include the PegaKMPortal:07-21 ruleset that is placed above any Pegarulesets

I did this but when I switch to the KMPortal it does not look like the same as the KMPortal that I see when I use the shiiped KMpublisher accesgroup. I don't see the left panel with the Dashboard, work, Knowledge... menu options. Instead I see a header with menu options for Onboarding wizard, search case types, update case types, etc.

***Edited by Moderator Marissa to update SR Details***

Group Tags

Correct Answer
June 19, 2019 - 2:18pm

After talking with Pega Support I learned that I needed to create a new application based on PegaKM and add my rulesets to that new application.  Additionally I copied and updated the shipped  publisher and approver access groups and pointed them to my new app.  The PegaKM application uses a different skin than CustServ.  Originally I tried to create a new KM application using CustServ as the basis.  That helped a little but the UI was corrupted because of the different skins.   With this latest change the UI is correct and I can choose my roles from the taxonomy Authorized Role drop down.

None of this is really mentioned in the KM user guide.

Comments

Keep up to date on this post and subscribe to comments

Pega
June 12, 2019 - 10:10am

Hi,

A good place to start might be to compare the KMPublisher access group with your own, to see what the differences are.  If any of the elements are missing (and don't have equivalent elements, such as your own user roles replacing the PegaRULES:**** roles), try adding them in and see if that changes the behavior. 

You could also compare your application with the application used by the KMPublisher access group to see if there are any rulesets you might not have.

Additionally, you could check the KMPortal, and the rules contained within it, to see if any of the rules it uses have been overridden in your application.  If a rule is customized based on the base platform in your application, but has overrides in the KM rulesets, the KM overrides might not get picked up.

Hope this helps!

-Kurt

June 13, 2019 - 10:17am

That helped a little.  I'm using pega cust serv.  I copied the access group CustServ:Administrators to create CustServ:KMAdministrators.   I added the KMportal and KM publisher role to the AG  and added the PegaKMportal:07-22 ruleset to my application  per the user guide's suggestion.    After comparing my access group with the KMPublisher I noticed that the PegaKM:CommunityUser and PegaRULES:User4 roles were missing.    Now I can see the normal Pega KM menu options like Dashboard, community, and taxonomy.  However they appear at the top of the screen instead of down the left side.  The UI is not usable because there are no horizontal or vertical scoll bars.   The UI does not look like it should.

John

 

Pega
June 14, 2019 - 7:39am

Hi JohnB097,

Can you please try saving as KM:SYSADMIN access group,which is administrators access group form KM framework and check whether it is working or not.

June 17, 2019 - 4:32pm

So far nothing has helped.   In the end I'm trying to use the Authorized Role drop down while editing my Taxonomy.   I've copied the KM:SysAdmin access group and changed the  Application to  CustServ 01.01.01.  I needed to do this to in order to add the CustServ:BackofficeUser role to the access group. Now I can see the CustServ:BackofficeUser role in the Authorized Role drop down but the UI is not usable.    All of the KM menu options are displayed at the top of the UI like a header.   The right pane is shown on the bottom and is very small.   I was able to scroll down to click the taxonomy edit button and see the correct values for the Authorized Role drop down.   

To troubleshoot this I've logged out cleared by chrome cache and logged in again.   The same issue appears.  The UI is corrupt and not usable.   See the attachments to see my config and results.

 

 

 

June 17, 2019 - 4:50pm

I've created   

  to 

June 19, 2019 - 2:18pm

After talking with Pega Support I learned that I needed to create a new application based on PegaKM and add my rulesets to that new application.  Additionally I copied and updated the shipped  publisher and approver access groups and pointed them to my new app.  The PegaKM application uses a different skin than CustServ.  Originally I tried to create a new KM application using CustServ as the basis.  That helped a little but the UI was corrupted because of the different skins.   With this latest change the UI is correct and I can choose my roles from the taxonomy Authorized Role drop down.

None of this is really mentioned in the KM user guide.

Mod
June 19, 2019 - 10:23pm
Response to JohnB097

Hi John,

Thank you for updating the steps to resolve this issue. We have logged in a documentation bug to adress the information gap in the Pega KM user guide. I have updated the bug id under Related Support Case Number field in the original post above. I will update this thread with any updates on the bug.

We will mark this post as Answered.

Lochana | Community Moderator | Pegasystems Inc.

Pega
July 12, 2019 - 3:02am
Response to JohnB097

as per the documentation, you need to create a new application built on top of PegaKM application. You can create new ruleset and add it to your new application for making any customization. By Default pegaKM uses KMEndUser71 skin and if you want to extend it, then inherit KMEndUser71 in your new application skin ( this will be auto created if you follow the steps mentioned in implementation guide).