Question

Launch Portal Error ---- On Clicking on Launch portal Pega throws an exception error

On Clicking on launch portal button in designer studio, pega is throwing exception in Dev environment not seeing this issue in all other environments, verified AG, portals roles and application everything is same.

below is the error i am seeing in logs

Section 'pzGetMenu' execution error on page 'pyDisplayHarness' of  class 'Data-Portal-DesignerStudio'. 

please assist

Correct Answer
August 7, 2019 - 3:45pm

We recently faced similar issue in one of our test environments which turned out to be caused by an withdrawn portal rule. In our case, exception on log file made it clear what the issue was about.

As per your screen-shot of log, no exception details is really logged (which is a bit odd). Can you please try following points:

1. Revalidate-and -save the access group that is in use when you tried to launch the portal. 

2. If you don't get any issue when revalidating the access group rule, try to trace the exception. I'm expecting the tracer tool will at least pin point the issue with your setup. Make sure in tracer setting you select all the PRPC OOTB rulesets.

Comments

Keep up to date on this post and subscribe to comments

August 7, 2019 - 3:45pm

We recently faced similar issue in one of our test environments which turned out to be caused by an withdrawn portal rule. In our case, exception on log file made it clear what the issue was about.

As per your screen-shot of log, no exception details is really logged (which is a bit odd). Can you please try following points:

1. Revalidate-and -save the access group that is in use when you tried to launch the portal. 

2. If you don't get any issue when revalidating the access group rule, try to trace the exception. I'm expecting the tracer tool will at least pin point the issue with your setup. Make sure in tracer setting you select all the PRPC OOTB rulesets.

August 7, 2019 - 4:15pm
Response to N.SenSharma

Thank you. i was able to figure out the issue by re-validate and save. Issue was with an access group where it has a portal with errors