Question

Labels' text is wrapping to 2nd line using "Stacked with labels left" dynamic layout

Hi all

I have a section configured to use the OOTB "Stacked with labels left" dynamic layout. The label width's default size is 120px and I am not allowed to check out and modify any skin (because my project lead said so)

So I am wondering is there any option to ensure that the labels' text will display in a single line?

Instead of:

"Secondary

Preferred Phone: "

It should be "Secondary Preferred Phone: "

Please see attached screenshot.

THANKS!!

**Moderation Team has archived post**

This post has been archived for educational purposes. Contents and links will no longer be updated. If you have the same/similar question, please write a new post.

Comments

Keep up to date on this post and subscribe to comments

July 24, 2018 - 1:33am

Please see also the Cell properties and presentation options as attached.

Thanks

July 24, 2018 - 2:25am

Just an update, I managed to find a config in the advanced properties where I can put "nowrap" to prevent the label from wrapping. However, this caused some issues on the labels' alignment. 

Please see attached. Any advice will be appreciated. Thanks

Pega
July 24, 2018 - 6:18am

Hi,

If you want to put the label in 120px width, then one option is to reduce the font of the label.

If you want to increase the label width for all the elements under the format(Stacked with labels left) you are using, you can create a non auto generated section with below snippet and include it in your section:

<style>

.content-stacked_with_labels_left>.content-item>.content-inner>.field-caption {     

 width: 220px !important;    // change based on your label length 

}
</style>

Hope it helps!!

Thanks.