Question

java.lang.RuntimeException: Component stack mismatch

Our application has been upgraded to 7.3.1 an year ago and since then, on a random basis, users are getting Harness failure error. When verified in logs, we saw a RunTimeException which says,

java.lang.RuntimeException: Component stack mismatch {"section":"XXXX","ver":"1","objClass":"Rule-HTML-Section","class":"XX-YY-ZZ","RO":"false","sectionBaseRef":"","expandRL":"","UID":"SID1548168960812","outerGadget":"GID_1548168960803","pyName":"pxSection","pyTemplates":[{"NTId":"1548168960810000","NTRef":"377a281255308411b9d9c369082c39b9_2","pyName":"pxNonTemplate"}]}!!!!===={"containerType":"CENTER","isClientWhen":false,"isVisibilityOption":"","pyName":"pxHarnessContainer","pyTemplates":[{"whenId":"3446558839592bbdd282724cb6956d2e_4","pyName":"pxVisible","pyTemplates":[{"NTId":"1548168960776000","NTRef":"8bb8687bb6525f4960bf3d5bee28fae1_1","pyName":"pxNonTemplate"}]},{"pxReferencedId":"3446558839592bbdd282724cb6956d2e_5","pyName":"pxSection"}]}

This being random, we are not able to pinpoint the issue. Also, it is occurring in several places of the application but the common part is that, the sections have a repeating list in the form of a Table or row repeat etc.,

So, I wanted to check here before raising an SR. Anyone who has faced this issue and found a solution, please suggest.

Thanks in advance!!

Correct Answer
April 1, 2019 - 11:52am

The issue was with failed when rule in the section. There was a RuntimeException around the same time which had the rootcause pointed at.

Comments

Keep up to date on this post and subscribe to comments

Pega
March 11, 2019 - 2:53am

Hi ,

Complete logs may help.

March 12, 2019 - 5:18pm
Response to sahuv1

Please find attached log instance of that issue

March 12, 2019 - 5:18pm
Response to divyasripadarthy

I have gone through this conversation before raising this question. That speaks about 8.1.3 patch for which we do not have plans for.

March 11, 2019 - 5:49am

Can you confirm if you are getting harness related(eg: NullpointerException) errors related to "DisplayharnessWithClass". Also, please share with us the complete logs.

March 12, 2019 - 5:16pm
Response to Rachit_Agarwal

I do not see any such error before or after this issue.

Pega
March 12, 2019 - 9:23am

Hi ,Have you tried revalidating and saving ? Sometimes issues like these gets resolved by revalidating those sections . 

or Do a private edit and save that and check if the exception is still appearing .

March 12, 2019 - 5:15pm
Response to bathb

Intentionally, I am not able to reproduce it but, there are multiple instances of this issue in the logs every day.

April 1, 2019 - 11:52am

The issue was with failed when rule in the section. There was a RuntimeException around the same time which had the rootcause pointed at.

November 7, 2019 - 8:28pm
Response to GOUTHAMKUMAR

Can you please elaborate ? 

 

We too have the similar exception and a runtime exception but not able to find any missing rule in the exception log.