Question

Interrogation Form doesn't recognize buttons

Hi team,

I'm having an issue by interrogating the CRM application with the interrogation form. As you can see in the image I've attached, the List Windows doesn't display the New Call, User 1, User 2. etc.

This is part of the "Pega Robotic Automation Architect Essentials Course" exercises.

How do I do to add those buttons to List Windows? Is someone else facing the same issue?

Thanks in advance.

Comments

Keep up to date on this post and subscribe to comments

Pega
October 21, 2019 - 2:58pm

Hi JacoboV5,

Thank you for your question. Please also include a screenshot of Pega Robotics Studio. This would help diagnose the issue with "List Windows". 

From what I can see in the "error.png" file attached, it seems like you are interrogating the toolbar instead of the individuals buttons. Make sure the black outline is around the element you are trying to create a control for before releasing the mouse button. I have included a screenshots for reference.

 

October 22, 2019 - 9:57am

Thank you for answering my query,

 

Actually I have the same list items as yours on the "list windows example.png image", and I can highlight the toolbar only. I attached another screenshot where you can see the hierarchy tree. Toolbar was added successfully but the buttons are not showing and I already tried several times to release the mouse button on different places but is still the same.

 

By the way, I did not have any issue to interrogate the login window, listed as "CRMfrmLogin" on the hierarchy tree.

Pega
October 22, 2019 - 12:47pm

Thanks for the screenshot. Please inform me of the version of Pega Robotics Studio you have installed.

If you are not sure how, click on "Help > About Pega Robotics Studio". This will open a window with version number.

October 22, 2019 - 1:16pm

Thanks for reply so quickly, the PEGA studio version is 8.0.2014.0, found it on the screenshot. 

Pega
October 24, 2019 - 3:45pm

I went ahead and tested interrogating the CRM app on the version of Pega studio that you have installed (8.0.2014.0) on a windows 10 machine. I was able to interrogate the buttons on the application. 

I recommend reinstalling the version of Pega Studio you have or if possible updating the latest version. Please let me know if this does not resolve your issue or if you have already tried this solution.

October 24, 2019 - 4:36pm
Response to odeyj

Actually I'm using Windows 7 Professional Service Pack 1 because I had to migrate to this version due to incompatibility with Windows 10. I already reinstalled Pega and unfortunately the issue persist.

Thank you.