Question

How to pass the body of request in urlencoded form?

We have the same issue as stated in this post: connector with Content-type application/x-www-form-urlencoded is not supported

Where we have to pass the body of request in urlencoded form and i'm not sure how exactly that is done in Pega Connect-REST.

***Edited by Moderator: Lochan to branch reply to create new post***

Branched Post Information: 

Comments

Keep up to date on this post and subscribe to comments

August 10, 2019 - 8:24am

What is your Pega version? I can see the post mapping type option in 8.2.x. See the screenshot below.

October 31, 2019 - 2:52am

Hi Kevin,

I have a similar requirement and in version 7.2 , the options for Message data is as per attachment. I receive Bad Request error on leaving it blank. Could you please provide any suggestion.

Regards,

Aparna

October 31, 2019 - 2:59pm
Response to AparnaGopakumar

Aparna, check my reply to your post.

October 31, 2019 - 11:47pm

Assuming you are using HTTP POST and your request body should be name=foo&action=open, you will need to construct such a string manually, set it to a property and then use Map from as Clipboard and Map from key as the property on the Request tab under POST in REST Connector. While constructing the string, make sure every "name" and "value" in name=value pair is URL encoded and every name=value pair is separated by an ampersand (&).