Question

Forgot changed admin password after logged into Pega 8.1.

Hello Experts,

After the 8.1 installation, I logged in and changed the "administrator@pega.com" password. I forgot what that password is and I am not able to login to the PRPC 8.1 system. Is there anyway I can reset the password or any other operator ID's I can use for the first time login? Any help regarding this matter is highly appreciated.

Correct Answer
November 12, 2019 - 3:00am

Hello,

for changing this specific operator password you cannot use standard operator menu.

Click on your operator link (top right for PEGA 7*, or bottom left for PEGA 8) and click on profile

There, you've got "change password" option.

If it's what you did, then I've got no clue :)

Regards

Anthony

 

Comments

Keep up to date on this post and subscribe to comments

January 3, 2019 - 2:20pm

Hi Srini,

Firstly, Pega doesn't recommend to change the administrator@pega.com operator until unless you have another way into your application. As soon as we log into the new installation application need to create an Admin access operator and make sure we can able to log into the system with it.

I have the below options at this point of time for you:

  1. Try to login with DatabaseAdmin@pega.com/install or Admin@DMOrg/install. If you are able to log in with this operators then create a new operator with Admin access and use that operator to change the password for administrator@pega.com operator as a best practice.
  2. If you are not able to login with any of those 2 operators then you can delete the administrator@pega.com from pr_operators table and run the upgrade scripts to get it recreated.
  3. Lastly you can start over and reinstall the application if above doesn't work.

Note: Once you change the password for administrator@pega.com it is advisable to store it somewhere, so that it can be retrieved on need basis.

Hope this might help you to achieve your requirement.

Regards

Mahesh M

November 11, 2019 - 9:15am
Response to Mahesh Midthuru

I managed to login as administrator@pega.com, but still unable to change my own password. Receive the error message: You are not authorized to create, modify, or lock instance DATA-ADMIN-OPERATOR-ID ADMINISTRATOR@PEGA.COM

November 11, 2019 - 10:27am
Response to MostafaR

So you're trying to modify a password of ADMINISTRATOR@PEGA.COM? Or your own password (of another operatorID)?

November 12, 2019 - 3:00am
Response to MostafaR

Hello,

for changing this specific operator password you cannot use standard operator menu.

Click on your operator link (top right for PEGA 7*, or bottom left for PEGA 8) and click on profile

There, you've got "change password" option.

If it's what you did, then I've got no clue :)

Regards

Anthony

 

November 12, 2019 - 5:56am
Response to Anthony_Gourtay

Oh, yes! This was it :) Thanks a lot, did not know that for administrator@pega.com you can only change it through profile page.

January 3, 2019 - 2:32pm

Thanks Mahesh for your quick response. Looks like 1 is not an option for me as the operators are disabled. I will try to do step#2 and see if it resolves my issue. I hope there is a way to enable one of the operators from backend.  I will keep you posted.

January 3, 2019 - 3:07pm
Response to Srini Bhupathiraju

I don't think there is an option to enable the operator from back end.