Question

Flow Problems with automatic instantiation of child case

Hi all,

I am facing an issue when creating child cases in Pega 7.3.1. I have set on pyDefault to create child cases with automatic instantiation based on a condition. This is working fine except that my child cases most of the time have two problem flows and and one actual flow. (see screenshot)

When I click on one of the ProblemFlows I see the problem is in Workflow pzInternalProcessFlow on step Assignment63 and the error message says that the routing information are missing.

My actual ECM flow is created before the two errorflows and I don't understand why it then still creates additional flows?

Comments

Keep up to date on this post and subscribe to comments

June 21, 2019 - 3:52pm

pzInternalProcessFlow is an internal flow that gets automatically invoked when you have SLAs configured for your flow. I see Work-.ToCurrentOperator execute when pzInternalProcessFlow is invoked for my child task. Can you trace the process to check the data and steps in this activity?

June 24, 2019 - 10:53am
Response to CarissaW_GCS

Hi, am actually not able to reproduce this issue on DEV. The issue appears on higher environments via JMS listener. I have seen on DEV that Assign-.ToCurrentOperator is called with param "System" on cases where it is working.

June 24, 2019 - 12:40pm
Response to MarvinH7

Is your JMS Listener associated with a specific requestor user ID? The Work-.ToCurrentOperator activity will call pyToAlternateOperator if Param.AssignTo=="System" since System is not a valid User ID for assignments. Param.AssignTo would then be set to pxCreateOperator if it is not empty. 

June 25, 2019 - 2:58am
Response to CarissaW_GCS

The JMS listener has configured an admin as requestor user id. Actually we call later in the flow (automated) createworkpage activity which creates the parent case and the child (which has the flow problems). In parent and child is no createoperator filled. 

June 25, 2019 - 5:52am
Response to MarvinH7

I am able to reproduce this issue. The assignments for internal flows are assigned to default workbasket which is identified by ToOverallSLA activity.

The AssignTo param is calculated by appending 'pxRequestor.pxOrganization' to 'default@' value. Can you please validate if that workbasket exists in the production system for the admin requestor ?

If it doesn't, please update the organization unit for the admin in the production system or create a workbasket with the existing organization name.

June 26, 2019 - 4:04am
Response to BharathKakaraparthi

Hi,

the workbasket exists in production and also the team of the workbasket and the admin are same just work group differ. Further more in the work group the admin role is not entered as authorized manager and in managers there is a role entered which does not exist on production.

Could this cause the issue? Or should I also change the work group of admin?

June 26, 2019 - 4:30am
Response to MarvinH7

Is the organization name in work basket (which comes after 'default@') same as the organization name mapped to admin operator?

June 26, 2019 - 4:38am
Response to BharathKakaraparthi

Name, Division and Unit have the same in Workbasket and Admin Operator but they both don't include the 'default@'.

June 26, 2019 - 4:58am
Response to MarvinH7

I think pxOrganization is not getting populated on pxRequestor while execute JMS listener service.

 https://community1.pega.com/community/pega-product-support/question/how-set-pxorganization-pxrequestor-page

To identify the root cause, can you please validate if pxOrganization property existing on the pxRequestor page either by adding a log statement or by adding pxRequestor to the additional pages while tracing the service

July 11, 2019 - 8:18am
Response to BharathKakaraparthi

Hi,

pxOrganization seems correct to me. But in the childcase doesn't have a pxCreateOperator on the pyWorkpage. I am wondering if it makes a difference if I create a childcase within the flow instead of using pyDefault settings?

 

Pega
June 21, 2019 - 7:39pm

Can you check if something is related to the below pdn link?

https://community.pega.com/support/support-articles/sla-rule-problem-if-it-included-flow-level-services

It has the similar error:

2015-10-20 12:47:30,263 [p-bio-8443-exec-5780] [ STANDARD] [ Ops:01.01.01] ( FlowProblems.Work_.Action) ERROR SOAP|JURISService|JURIS|CreateClaimRequest|A3296C9E28B5C14721A7029355F4C57C3 Operator- Problem flow abort due to system flow FlowProblems being the issue

2015-10-20 12:47:30,807 [p-bio-8443-exec-5780] [ STANDARD] [ Ops:01.01.01] ( ResumeFlow.Work_.Action) ERROR SOAP|JURISService|JURIS|CreateClaimRequest|A3296C9E28B5C14721A7029355F4C57C3 Operator- Flow pzInternalProcessFlow had an error in step ASSIGNMENT63: No routing information was provided for this assignment

 

 

June 24, 2019 - 10:50am
Response to SusanLiu

Hi, I have checked all activities in regards to my case types however the check box for authentication is already checked.