Question

Failing Azure Repository Creation

Environment details: PRPC 8.2.1 on Azure could

Trying to create Azure repository from the export application wizard. I have followed up the steps to create the Azure repository including setting up my authenticate profile. Please find the screenshots of the each steps.

Test Connectivity button is not enabled at all. Please guide me on how to create the azure repository from PRPC 8.2

***Edited by Moderator Marissa to update SR Details***

Group Tags

Comments

Keep up to date on this post and subscribe to comments

June 6, 2019 - 7:49pm

I saw the java exception when saving the repository. Please attach the pega rules log so that we can examine the full error stack.

June 6, 2019 - 10:09pm

Added PegaRULES log in txt format

June 11, 2019 - 9:11pm

Here is the reason - please name your container as lower case and retest.

2019-06-06 14:49:09,875 [http-nio-8080-exec-9] [TABTHREAD4] [                    ] [         PegaRULES:8] (alidate.Data_Repository.Action) ERROR humanapocdev.southindia.cloudapp.azure.com|96.28.113.182 pegadeploy - Validation on '[java.lang.String arg0]' didn't pass:
 Reason: Object 'AzureContainer' doesn't match Azure container naming convention. Reason: Should be only lowercase. For more info, please refer to http://weblogs.asp.net/vblasberg/archive/2009/02/17/azure-details-and-limitations-blobs-tables-and-queues.aspx..
java.lang.IllegalArgumentException: Validation on '[java.lang.String arg0]' didn't pass:
 Reason: Object 'AzureContainer' doesn't match Azure container naming convention. Reason: Should be only lowercase. For more info, please refer to http://weblogs.asp.net/vblasberg/archive/2009/02/17/azure-details-and-limitations-blobs-tables-and-queues.aspx..

June 12, 2019 - 10:03am
Response to KevinZheng_GCS

Hi Kevin -

Thanks for the reply. The container error we fixed at the 1st pace itself (it was self explanatory) and is not an issue any more. 

There are other exceptions in the log file.

Pega
December 5, 2019 - 3:36pm
Response to JaikumarND

Hi Jaikumar, 

Were you able to fix this issue? I'm facing the same problem.