Question

Facing Compilation Issues in Library/ Functions post importing Custom Jars. com.pega.apache.poi.hssf.usermodel.*

Hi Team,

We have recently upgraded from Pega 7.1.7 to Pega 7.4, post which we are unable to compile custom functions/ library

GEtting the below error:

The import com.pega.apache.poi cannot be resolved.

com.pega.apache.poi.hssf.usermodel.* cannot be resolved.

have seen many articles related to this in PDN but not getting any correct resolution.

We understand that post 7.2.2 release com.pega.apache.poi is replaced with org.apache.poi but we need some solution to overcome this.

**Moderation Team has archived post**

This post has been archived for educational purposes. Contents and links will no longer be updated. If you have the same/similar question, please write a new post.

Comments

Keep up to date on this post and subscribe to comments

Pega
July 9, 2018 - 10:17am

Hi

It looks like you may have to recompile the custom jars to be in line with newest jars.
hence I suspect you may have to alter the import statements in your custom jar to refer something like  "org.apache.poi.*" instead.

July 12, 2018 - 2:48am
Response to ManuV_GCS

Hi Thanks for the reply, I have tried the above and still facing the issue. 

Pega
July 12, 2018 - 4:57am

Manu' answer looks correct to me.

Which function is failing to compile ?

Double check the pr_engineclasses tables to see what the package names are.

For example:

  1. SELECT distinct(package) FROM pr_engineclasses
  2.  
  3. WHERE LOWER(pzpackage) like '%poi%';

 

July 13, 2018 - 4:13am
Response to JOHNPW_GCS

Hi John, 

We have around 18 functions with the same library. out of which com.pega.apache.poi referenced in 3 functions, i have modified it to org.apache.poi and tried to compile it but could not save as its throwing the error "cannot be resolved", faced the issue with all other 15 functions as we are using the same library name.

I queried to DB select distinct(pzpackage) from pr_engineclasses where lower(pzpackage) like '%poi%'; and i can able to see the packages for 

com/pega/apache/poi and org/apache/poi too.. We are working with GCS team now to resolve the issue.