Question

Error while starting Decision Data Store Service in Pega 8.2.1

We recently installed Pega 8.2.1 platform with Pega Customer Service for Healthcare. When we try to start the Decision Data store service from "Decisioning->Infrastructure->Services->Decision Data Store" Landing Page, the service start up fails with Status "JOINING_FAILED". When i clicked on the status message, i see the exception message as "SessionNotAvailableException: Unable to obtain session. Cassandra hasn't been started or is unavailable"

The exception trace itself is as given below.

com.pega.dsm.dnode.api.dds.service.SessionNotAvailableException: Unable to obtain session. Cassandra hasn't been started or is unavailable
at com.pega.dsm.dnode.api.dds.service.CassandraSessionCache.getSession(CassandraSessionCache.java:114)
at com.pega.dsm.dnode.api.dds.service.CassandraSessionCache.getSessionWithoutAwaitingDdsService(CassandraSessionCache.java:147)
at com.pega.dsm.dnode.api.DdsService.getStartupSession(DdsService.java:995)
at com.pega.dsm.dnode.api.DdsService.access$1600(DdsService.java:81)
at com.pega.dsm.dnode.api.DdsService$DdsStartOperation$2$1.execute(DdsService.java:210)
at com.pega.dsm.dnode.util.OperationWithLock$1.execute(OperationWithLock.java:64)
at com.pega.dsm.dnode.util.OperationWithLock$LockingOperation.couldAcquireLock(OperationWithLock.java:163)
at com.pega.dsm.dnode.util.OperationWithLock$LockingOperation.performLockOperation(OperationWithLock.java:130)
at com.pega.dsm.dnode.util.OperationWithLock$LockingOperation.access$200(OperationWithLock.java:75)
at com.pega.dsm.dnode.util.OperationWithLock.doWithLock(OperationWithLock.java:72)
at com.pega.dsm.dnode.util.OperationWithLock.doWithLock(OperationWithLock.java:68)
at com.pega.dsm.dnode.util.OperationWithLock.doWithLock(OperationWithLock.java:49)
at com.pega.dsm.dnode.impl.prpc.service.ServiceHelper.executeWithLockInternal(ServiceHelper.java:204).

At the of the trace i see this message

at com.pega.dsm.dnode.impl.prpc.PrpcThreadFactory$PrpcThread.run(PrpcThreadFactory.java:109)
Caused by: com.datastax.driver.core.exceptions.NoHostAvailableException: All host(s) tried for query failed (tried: /10.201.114.25:9042 (com.datastax.driver.core.exceptions.TransportException: [/10.201.114.25:9042] Cannot connect))
at com.datastax.driver.core.ControlConnection.reconnectInternal(ControlConnection.java:233).

We have installed Pega 8.2.1 on Websphere with DB2 as the database. Pega 8.2.1 instance is installed within an IBM AIX LPAR that has other Pega 7.2.2 instances runnning. Not sure if that effects, but just wanted to share that information.

Request help on this if someone has faced this issue before, and how we can resolve this.

Thanks,

Swami

Comments

Keep up to date on this post and subscribe to comments

June 11, 2019 - 9:06pm

Have you ever successfully added the node to DDS service? If not, can you decommission the node, delete the cassandra_data directory and re-add? Also make sure you can connect to the ip/port indicated in the log (e.g., using telnet ip port).

Pega
June 13, 2019 - 10:38am

Hi,

The issue is because cassandra services has not started yet.

com.datastax.driver.core.exceptions.NoHostAvailableException
The above exception can occur cassandra nodes are no longer listening over the configured port.

To resolve the issue decommission the node from DDS landing page and add it again.