Question

Error when creating branches

Hello,

I'm trying to create a branch "ABC" in my application, however, I get an error saying "invalid division name" the first time I try to save and when I try to save it the second time it says "this Branch already exists in the system"

Is there any other way to create a branch for parallel development? what are these errors?

Correct Answer
December 12, 2019 - 1:47pm

I see the "Invalid Division Name" error message in the Rule-Application.ValidateOrgDivUnit activity. Check the organization data on the Documentation tab of your Application rule. It should be towards the bottom. Make sure the record for the division exists.

Comments

Keep up to date on this post and subscribe to comments

December 12, 2019 - 1:47pm

I see the "Invalid Division Name" error message in the Rule-Application.ValidateOrgDivUnit activity. Check the organization data on the Documentation tab of your Application rule. It should be towards the bottom. Make sure the record for the division exists.

December 12, 2019 - 3:08pm
Response to CarissaW_GCS

Thanks, Carissa.

Organization data was not updated in the Application rule, after the update, I don't get the same error.

*** Where can I find Rule-Application.ValidateOrgDivUnit activity???

 

December 12, 2019 - 3:20pm
Response to DeepakY0

It is an internal rule so it does not show up in the search by default. You can modify your preferences so the internal rules are displayed in the search results (as long as you have the search indexes built). Click on your Operator icon, select Preferences, and check the 'Enable diagnostic features' box at the bottom.